lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael McCandless <luc...@mikemccandless.com>
Subject Re: trouble with permissions?
Date Thu, 01 Feb 2007 21:33:41 GMT
Miles Efron wrote:
> i seem to be having a problem analogous to this one (no answer that i see):
> 
>     http://www.gossamer-threads.com/lists/lucene/java-user/32268?search_string=cannot%20overwrite;#32268

> 
> 
> trouble is, i just put lucene on my new macbook pro and am having the 
> problem that if i build a large index, i get an I/O error due to 
> something like
> 
>     java.io.IOException: Cannot overwrite: 
> /data/reuters/indexes/reuters/deleteable.new
> 
> same code worked fine on my previous machine (still running on a G4 
> powerbook and a linux machine).  sometimes it has trouble writing the 
> segments file instead...
> 
> has anyone seen and solved this problem?  thoughts on what might be 
> behind it?

Are you running Windows on your macbook pro?

There are known issues like this, but only on Windows, eg:

   http://issues.apache.org/jira/browse/LUCENE-665

We believe such cases are now fixed by lockless commits, on the trunk
of Lucene (which is not yet released).  If you could try the trunk
(but beware that API, file formats, can change) and see if this still
happens that'd be great!

Mike

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message