lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Van Nguyen" <vngu...@ur.com>
Subject RE: Caused by: java.io.IOException: The handle is invalid
Date Tue, 26 Sep 2006 16:31:26 GMT
I'm running this on Windows 2003 server (NTFS).  The Java VM version is
1.5.0_06.  This exception is not consistent, but it is not intermittent
either.  It does not throw it at any particular point while rebuilding
the index, but it will throw this exception at some point (it could be
1/3 way through... or it could be 95% done).  

At first... I thought I might have a bad sector somewhere on my hard
drive, so I partitioned a hard drive (known to be good) to be only
500mb... knowing this particular index is only 250mb.  Using the server
version of the jvm.dll will cause this error somewhere during program.
Using the client version, it builds w/o any errors.

Van

-----Original Message-----
From: Michael McCandless [mailto:lucene@mikemccandless.com] 
Sent: Tuesday, September 26, 2006 6:38 AM
To: java-user@lucene.apache.org
Subject: Re: Caused by: java.io.IOException: The handle is invalid

Van Nguyen wrote:

> I only get this error when using the server version of jvm.dll with my

> JBoss app server... but when I use the client version of jvm.dll, the
same 
> index builds just fine. 

This is an odd error.  Which OS are you running on?  And, what kind of 
filesystem is the index directory on?

It's surprising that client vs server JRE causes this.

Is the exception easily reproduced or is it intermittent?

Mike

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org
Mime
View raw message