lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Puneet Lakhina" <puneet.lakh...@gmail.com>
Subject java.io.IOException: Lock obtain timed out: Lock@/tmp/lucene-dcc982e203ef1d2aebb5d8a4b55b3a60-write.lock
Date Sat, 15 Apr 2006 16:49:07 GMT
Hi all,
I am very new to lucene. I am using it in my application to index and serach
through text files. And my program is more or less similar to the demo
privided with lucene distribution.
Initially everything was working fine without any problems. But today while
running the application i have been getting this exception

java.io.IOException: Lock obtain timed out: Lock@/tmp/lucene-
dcc982e203ef1d2aebb5d8a4b55b3a60-write.lock

whever i try to read or write to the index. I am unable to understand why
this is happening. IS there some mistake I am making in the code.. because I
havent changed any code, which was working smoothly up until today!!!

My version of lucene is 1.9.1

I deleted the index directory and tried again and voila now it works again!!
But if I am going to be delivering my application I would really like to
know why this was happening to guard against it..

Thanks
--
Puneet

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message