lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Keegan" <peterlkee...@gmail.com>
Subject Re: Throughput doesn't increase when using more concurrent threads
Date Fri, 17 Mar 2006 18:12:03 GMT
Good question. 'Top' reports the jvm at 99.9% CPU, but the individual CPUs
(top/1) don't seem to add up to 99.9. This server is actually 2 - 8 CPU
servers whose backplanes are cabled together, so there may be some issue
here.  The network load is heavy, but doesn't seem to be the bottleneck (on
the Opteron server, the network is very close to being the bottleneck).
There is an expected monitor lock on an ArrayBlockingQueue, but it isn't
starving that thread.
So, at this point, I'm suspicious about the hardware setup.

Peter

On 3/17/06, Doug Cutting <cutting@apache.org> wrote:
>
> Peter Keegan wrote:
> > I did some additional testing with Chris's patch and mine (based on
> Doug's
> > note) vs. no patch and found that all 3 produced the same throughput -
> about
> > 330 qps - over a longer period.
>
> Was CPU utilizaton 100%?  If not, where do you think the bottleneck now
> is?  Network?  Or some other Java monitor contention?
>
> Doug
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-user-help@lucene.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message