lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mufaddal Khumri <mkhu...@allegromedical.com>
Subject Strange Problem ... Luke returns results Lucene api does not.
Date Thu, 16 Feb 2006 19:41:41 GMT
Hi,

I have a query that gets hits via luke. I can see the documents it 
finds. But when I run the same query via my java code it returns 0 hits.

Note:
1. I am using standard analyzer while indexing and searching.
2. I have made sure that I am querying the same index via luke or 
through my java program.

This is the call I make in my java code.
        BooleanQuery finalQuery = new BooleanQuery();
        .....
        .....
        log.debug(finalQuery.toString());

        hits = 
IndexSearcherManager.getIndexSearcher(indexPath).search(finalQuery);    
       

        log.debug("Hits length = " + hits.length());

The output of the first log statement above is:

+(+contentNew:Wireless +contentNew:fm +contentNew:car 
+contentNew:transmitter) +entity:category +(name:Wireless fm car 
transmitter^40.0 ((name:Wireless name:fm name:car 
name:transmitter)^10.0) contentNew:Wireless fm car transmitter^20.0 
(contentNew:Wireless contentNew:fm contentNew:car contentNew:transmitter))

The output of the second log statement above is:

Hits length = 0

I run the above query against the same index via Luke and I get search 
results that I expected.

Any ideas as to why my java call does not return any hits? how i might 
be able to debug this?

Thanks,


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message