lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Hostetter <hossman_luc...@fucit.org>
Subject Re: Delete doesn't delete?
Date Tue, 25 Oct 2005 05:32:36 GMT

can you provide some sample code that demonstrates this problem? ...
preferably something that uses hardcoded data to built up an index in a
RAMDirectory so ayone can run the test without needing any external data?

it would make it a lot easier for other people to help you diagnose what's
going on.


: Date: Mon, 24 Oct 2005 17:41:25 -0400
: From: Dan Quaroni <dquaroni@OPENRATINGS.com>
: Reply-To: java-user@lucene.apache.org
: To: java-user@lucene.apache.org
: Subject: Delete doesn't delete?
:
: I know there's a little bit of trickery when it comes to deletes (i.e. it's still in the
index until optimize, still available to open readers, etc) however I'm having this problem:
:
: I've implemented a call to delete by term.  It tells me that it deleted 1 item, but then
I go and open a new reader on the index, search for this document, and I find it.  Confused,
I run the delete again, and it once again tells me 1 document deleted.  And still, I can open
a new searched and search for it.
:
: I've tried closing the reader that I used to delete it, still no luck.
:
: Any suggestions?
:
: ---------------------------------------------------------------------
: To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
: For additional commands, e-mail: java-user-help@lucene.apache.org
:



-Hoss


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message