lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yonik Seeley <ysee...@gmail.com>
Subject Re: Boost value is lost
Date Wed, 21 Sep 2005 14:37:38 GMT
You don't get the boost back directly... it's folded into the "norm" for the
field and does affect the score when you search against the index.

-Yonik

On 9/21/05, Steve Gaunt <SGaunt@emeraldinsight.com> wrote:
>
> Hi all,
>
> I was hoping someone could shed some light on this?
> When I set a boost for a particular field during indexing, for example
>
> field.setBoost(1.5f);
> document.add(field);
>
> Then do a indexwriter.optimize();
>
> But when I do a search and get the document back, the boost value for
> that field has been reset back to the default value of 1.
>
> Has anyone else come across a similar situation??
>
>
> Cheers
>
> Steve
>
>
>
> ______________________________________________________________________
> This email has been scanned by the MessageLabs Email Security System.
> For more information please visit http://www.messagelabs.com/email
> ______________________________________________________________________
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-user-help@lucene.apache.org
>
>


--
-Yonik
Now hiring -- http://tinyurl.com/7m67g

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message