lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Morus Walter <morus.wal...@tanto.de>
Subject RE: Lucene on Linux problem...
Date Wed, 13 Apr 2005 06:38:29 GMT
Kristian Ottosen writes:
> 
> It seems to work now - but I would still love to see a good explanation.
> 
How was your java application started? (sorry I you already explained, 
I didn't keep the thread and the mailing list archive seems to be out 
of order)
I remember strange problems (with mkdir in my case) when using java
servlets within a tomcat that was started by apache daemon.
The problem occured on some linux installations only.
The reason we found after quite some debugging was, that daemon wasn't 
linked to libpthread, so java was somehow using the wrong libc (or something
similar, I never understood all details).
(daemon started, loading the unthreaded libc and handed control to the
java binary which continued using that libc while requireing a threaded)

I don't know if your problems have anything to do with such effects, but
when you say, it happens on some distributions while others work, that
comes into my mind.
If the same jar file works on one linux installation and fails on another
it's suggesting that the problem is on the jvm level or it's libraries.

Morus


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message