lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Elschot <paul.elsc...@xs4all.nl>
Subject Re: Compile lucene
Date Wed, 02 Feb 2005 20:25:32 GMT
Helen,

I downloaded lucene-1.4.3.zip myself from one of the mirrors
(http://apache.essentkabel.com/jakarta/lucene/binaries/)

It contains the lucene demo's, and not the java sources.

The lucene-1.4.3.tar.gz there has the same problem.

It seems something is wrong with the 1.4.3 distribution.

When you need the lucene 1.4.3 jar you can download it from the above mirror,
it looks ok. to me.

In case you have done something like this before:

The following command (on a single line) will checkout the source files from cvs
into directory lucene-1.4.3 (make sure that directory is empty beforehand):

cvs -d :pserver:anoncvs@cvs.apache.org:/home/cvspublic checkout -r lucene_1_4_3 -d lucene-1.4.3
jakarta_lucene

In there you can correct the build.xml file and do:

ant compile

to compile the source code.

Regards,
Paul Elschot


On Wednesday 02 February 2005 20:55, Helen Butler wrote:
> Hi Paul,
> 
> Thanks for your quick response.
> 
> The Build.xml was obtained from the Lucene-1.4.3.zip that I downloaded from the apache
website.
> 
> I changed the version in the xml file as you suggested, however the error persists.
> 
> Kind Regards,
> Helen Butler
> 
> 
> -----Original Message-----
> From: Paul Elschot <paul.elschot@xs4all.nl>
> To: lucene-user@jakarta.apache.org
> Date: Wed, 2 Feb 2005 20:39:01 +0100
> Subject: Re: Compile lucene
> 
> Helen,
> 
> On Wednesday 02 February 2005 20:26, Helen Butler wrote:
> > Hi
> > 
> > Im trying to Compile Lucene but am encountering the following error on 
> typing ant from the root of Lucene-1.4.3
> > 
> > C:\lucene-1.4.3>ant
> > Buildfile: build.xml
> > 
> > init:
> > 
> > compile-core:
> > 
> > BUILD FAILED
> > C:\lucene-1.4.3\build.xml:140: srcdir "C:\lucene-1.4.3\src\java" does not e=
> > xist!
> 
> It seems the java source files were not extracted.
> 
> How did you obtain the build.xml file?
> 
> Once the compilation works, you'll notice that the lucene jar being built
> has a 1.5 version number because of an incorrect version number
> in the 1.4.3 build.xml.
> You need to correct the version property in the build.xml file:
>   <property name="version" value="1.4.3"/>
> 
> Regards,
> Paul Elschot.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: lucene-user-help@jakarta.apache.org
> 
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: lucene-user-help@jakarta.apache.org
> 
> 
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-user-help@jakarta.apache.org


Mime
View raw message