lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Naber <daniel.na...@t-online.de>
Subject Re: 1.4.3 breaks 1.4.1 QueryParser functionality
Date Tue, 04 Jan 2005 23:19:07 GMT
On Tuesday 04 January 2005 23:53, Bill Janssen wrote:

>     protected Query getFieldQuery (String field,
>                                    Analyzer a,
>                                    String queryText)
>         throws ParseException

You're right, the problem is that we should call the deprecated method for 
example in getFieldQuery(String field, String queryText, int slop). 
However, there's a simple workaround: just remove the "analyzer" parameter 
from your method.

Regards
 Daniel

-- 
http://www.danielnaber.de
Mime
View raw message