lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Otis Gospodnetic <>
Subject Re: Weird Behavior On Windows
Date Tue, 07 Dec 2004 23:27:47 GMT
The index has been modified, so you need a new IndexSearcher.  Could
there be logic in the flaw (swap that), or could you be catching an
Exception that is thrown only on Winblows due to Windows not letting
you do certain things with referenced files and dirs?


--- Luke Shannon <> wrote:

> Hello All;
> Things have been running smoothly on Linux for sometime. We set up a
> version
> of the site on a Win2K machine, this is when all the "fun" started.
> A pdf would be added to the system. The indexer would run, find the
> new
> file, index it and successfully complete the update of the index
> folder. No
> IO error, no errors of any kind. Just like on the Linux box.
> Now we would try to search for a term in the document. 0 results
> would be
> returned? To make matters worse if I run a search on a term that
> shows up in
> a bunch of documents on windows it only find 2 results, where in
> Linux it
> would find 50 (same content).
> Using "Luke" I was able to verify that the pdf in question is in the
> index.
> Why can't the searcher find it?
> Any ideas would be welcome.
> Luke
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message