lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Hatcher <e...@ehatchersolutions.com>
Subject Re: single quote unicode character
Date Tue, 12 Oct 2004 01:12:13 GMT
Chris - I suspect something else in your application is getting in the 
way.  Try to simplify and eliminate the servlet, or use a tool like 
Luke to see what is truly in the index and what truly is being 
returned.  Lucene indexes what you tell it (perhaps your analyzer is 
manipulating things?), and returns what is stored exactly, so I doubt 
Lucene is the culprit.

	Erik


On Oct 11, 2004, at 8:50 PM, Chris Fraschetti wrote:

> The dataset that I index is pretty dynamic and flexible, and I started
> to notice a incorrectly displayed character on some of my results...
> some debugging showed that it was a the Unicode character for single
> quote which is 8217 decimal. As far as I know, everything is fine
> before I index, but when retrieving the content, I receive a character
> that cannot be displayed on the java servlet I use to display them.
> How can I make lucene be vary general and accept and return all
> encoded/non-encoded chars are they were in their original state?
>
>
> -- 
> ___________________________________________________
> Chris Fraschetti
> e fraschetti@gmail.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: lucene-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-user-help@jakarta.apache.org


Mime
View raw message