lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Tyrrell" <>
Subject RE: Indexing process causes Tomcat to stop working
Date Thu, 28 Oct 2004 08:13:44 GMT
>From: "Armbrust, Daniel C." <>

Right got back to work with newly created  index to try these ideas,

>So, are you creating the indexes from inside the tomcat runtime, or are you 
>creating them on the command line (which would be in a different runtime 
>than tomcat)?

I'm creating them on the command line using a variation on the standard 
shown in the demo (has some additional optimisation input that is set to 
default until I can fix this bug).

>What happens to tomcat?  Does it hang - still running but not responsive?  
>Or does it crash?
>If it hangs, maybe you are running out of memory.  By default, Tomcat's 
>limit is set pretty low...

It definately hangs when shutdown you can't access it, when re-started it 
just sits there trying to access  port 8080

>There is no reason at all you should have to reboot... If you stop and 
>start tomcat, (make sure it >actually stopped - sometimes it requires a 
>kill -9 when it really gets hung) it should start working >again.  
>Depending on your setup of Tomcat + apache, you may  have to restart apache 
>as well to >get them linked to each other again...

Good news this did work, however I never see tomcat in top or even using ps 
-A | grep tomcat, the only way I've found tomcat is using ps -auwx | grep 
tomcat. The output is

*after tomcat run*
root      2266  0.0  3.8 243740 4860 pts/0   S    Oct26   0:36 
/opt/jdk1.4/bin/java -Djava.endorsed.dirs=/opt/tomcat/common/endorsed 

-Dcatalina.base=/opt/tomcat -Dcatalina.home=/opt/tomcat
root     16050  0.0  0.4  3576  620 pts/0    S    08:41   0:00 grep tomcat

I did however find two java proccesses running so I duitifully used kill -9 
on both pid's, hey-presto when I restarted Tomcat it ran perfectly. So while 
I can work around this.... I think, I guess now the question becomes, does 
anyone have any advice as to what could be causing this? Bearing in mind I 
can still run java proccesses (even create new indexes) on the same machine 
so it is just Tomcat thats affected.

Meanwhile, I will try as Dan suggested to raise the default memory of Tomcat 
significantly and run another index (it seems a likely culprit).

Thanks for all the help thus far, its more than appreciated regards,


>----Original Message-----
>From: James Tyrrell []
>Sent: Wednesday, October 27, 2004 10:49 AM
>Subject: RE: Indexing process causes Tomcat to stop working
>       D'oh forgot to mention that mildly important info. Rather than
>re-index I am just creating a new index each time, this makes things easier
>to roll-back etc (which is what my boss wants). the command line is
>something like <java com.lucene.IndexHTML -create -index indexstore/ ..> I
>have wondered about whether sessions could be a problem, but I don't think
>so, otherwise wouldn't a restart of Tomcat be sufficient rather than a
>reboot? I even tried the killall command on java & tomcat then started
>everything again to no avail.
>To unsubscribe, e-mail:
>For additional commands, e-mail:
>To unsubscribe, e-mail:
>For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message