lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Tyrrell" <jr_tyrr...@hotmail.com>
Subject RE: Indexing process causes Tomcat to stop working
Date Thu, 28 Oct 2004 14:24:45 GMT

>From: iouli.golovatyi@group.novartis.com
Hello!

>before scewing tomcat too much...

A little late but probably good advice thankfully it hasn't gone wrong

>1.make it sure both indexing and reading processes use the same locking
>directory (i.e. set it explicitly, take a look in wiky how to)

working on this not so good at Java yet (until recently I mostly worked on 
Php) , looked on the wiki "how to's" could you be more specific as I 
couldn't find much on locking directories. But I will struggle on

>2. try to execute queries from command line and see what happends

I only exectute from the command line, so so all the info in previous posts 
is what happens

>3. in case your queries use sorting, there is a memory leak it 1.4.1 ->
>upgrade to 1.4.2

My queries do use sorting! So I have placed the 1.4 final jar onto my 
classpath and have started 'another' index, as the company I work for is 
moving home tomorrow may not be able to tell you if that worked till next 
week mind.

To Dan, the increased memory allocation for Tomcat didn't work unfortunately 
but I do  know a lot more about catalina_opt and Tomcat now which has proved 
handy for other things.

cheers for all the advice people will keep you posted if I make a 
breakthrough
thanks for your patience, regards,

JT

>Regards,
>J.
>
>"James Tyrrell" <jr_tyrrell@hotmail.com>
>28.10.2004 10:13
>Please respond to "Lucene Users List"
>
>
>         To:     lucene-user@jakarta.apache.org
>         cc:     (bcc: Iouli Golovatyi/X/GP/Novartis)
>         Subject:        RE: Indexing process causes Tomcat to stop working
>         Category:
>
>
>
> >From: "Armbrust, Daniel C." <Armbrust.Daniel@mayo.edu>
>
>Right got back to work with newly created  index to try these ideas,
>
> >So, are you creating the indexes from inside the tomcat runtime, or are
>you
> >creating them on the command line (which would be in a different runtime
> >than tomcat)?
>
>I'm creating them on the command line using a variation on the standard
>shown in the demo (has some additional optimisation input that is set to
>default until I can fix this bug).
>
> >What happens to tomcat?  Does it hang - still running but not responsive?
>
> >Or does it crash?
> >If it hangs, maybe you are running out of memory.  By default, Tomcat's
> >limit is set pretty low...
>
>It definately hangs when shutdown you can't access it, when re-started it
>just sits there trying to access  port 8080
>
> >There is no reason at all you should have to reboot... If you stop and
> >start tomcat, (make sure it >actually stopped - sometimes it requires a
> >kill -9 when it really gets hung) it should start working >again.
> >Depending on your setup of Tomcat + apache, you may  have to restart
>apache
> >as well to >get them linked to each other again...
>
>Good news this did work, however I never see tomcat in top or even using
>ps
>-A | grep tomcat, the only way I've found tomcat is using ps -auwx | grep
>tomcat. The output is
>
>*after tomcat shutdown.sh run*
>-------
>root      2266  0.0  3.8 243740 4860 pts/0   S    Oct26   0:36
>/opt/jdk1.4/bin/java -Djava.endorsed.dirs=/opt/tomcat/common/endorsed
>-classpath
>/opt/jdk1.4/lib/tools.jar:/opt/tomcat/bin/bootstrap.jar:/opt/tomcat/bin/commons-logging-api.jar
>
>-Dcatalina.base=/opt/tomcat -Dcatalina.home=/opt/tomcat
>-Djava.io.tmpdir=/opt/to
>root     16050  0.0  0.4  3576  620 pts/0    S    08:41   0:00 grep tomcat
>------
>
>I did however find two java proccesses running so I duitifully used kill
>-9
>on both pid's, hey-presto when I restarted Tomcat it ran perfectly. So
>while
>I can work around this.... I think, I guess now the question becomes, does
>
>anyone have any advice as to what could be causing this? Bearing in mind I
>
>can still run java proccesses (even create new indexes) on the same
>machine
>so it is just Tomcat thats affected.
>
>Meanwhile, I will try as Dan suggested to raise the default memory of
>Tomcat
>significantly and run another index (it seems a likely culprit).
>
>Thanks for all the help thus far, its more than appreciated regards,
>
>JT
>
>
> >----Original Message-----
> >From: James Tyrrell [mailto:jr_tyrrell@hotmail.com]
> >Sent: Wednesday, October 27, 2004 10:49 AM
> >To: lucene-user@jakarta.apache.org
> >Subject: RE: Indexing process causes Tomcat to stop working
> >
> >Aad,
> >       D'oh forgot to mention that mildly important info. Rather than
> >re-index I am just creating a new index each time, this makes things
>easier
> >to roll-back etc (which is what my boss wants). the command line is
> >something like <java com.lucene.IndexHTML -create -index indexstore/ ..>
>I
> >have wondered about whether sessions could be a problem, but I don't
>think
> >so, otherwise wouldn't a restart of Tomcat be sufficient rather than a
> >reboot? I even tried the killall command on java & tomcat then started
> >everything again to no avail.
> >
> >cheers,
> >
> >JT
> >
> >
> >
> >---------------------------------------------------------------------
> >To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
> >For additional commands, e-mail: lucene-user-help@jakarta.apache.org
> >
> >---------------------------------------------------------------------
> >To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
> >For additional commands, e-mail: lucene-user-help@jakarta.apache.org
> >
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: lucene-user-help@jakarta.apache.org
>
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-user-help@jakarta.apache.org


Mime
View raw message