lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Hatcher <e...@ehatchersolutions.com>
Subject Re: hit score in 1.3 vs 1.4
Date Fri, 11 Jun 2004 10:15:31 GMT
On Jun 11, 2004, at 6:12 AM, Erik Hatcher wrote:
> On Jun 11, 2004, at 5:51 AM, Stefan Groschupf wrote:
>> Hi,
>>
>> I'm having a strange problem until upgrading lucene 1.3 to 1.4 rc4.
>> I'm using a third party component that include the old lucene 1.3 but 
>> i need to run the new 1.4 rc 4 in the same vm.
>> So i unpack the component jar, remove all lucene 1.3 classes and 
>> repack it again and just add the new lucene in the classpath.
>> So far everything running well, but the hits.score(i) method return 
>> for each hit 100 %. ;-o
>>
>> Does someone has any idea where may be the problem can be?
>
> I'm not sure you'll have much luck with two versions playing well in 
> the sam VM together.  There are static variables used as well as JVM 
> system properties that factor into configuration settings.  I don't 
> have any specific recommendations, just a gut feeling that the issues 
> are not going to be pleasant.

Actually I think I misspoke.... you are not trying to run both versions 
in the same VM, but simply replace the old 1.3 version.  Maybe you 
should re-index?  There are factors computed at index time that may 
need to be re-done with the newer version of Lucene?

	Erik


---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-user-help@jakarta.apache.org


Mime
View raw message