lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "hui" <...@triplehop.com>
Subject RE: index on SAN (storage area network)
Date Fri, 14 May 2004 03:21:50 GMT
Thank you very much for the suggestion, Otis.
I did write a test program to check whether the directory is a directory.
But I did not test it within the web application. It is related with tomcat
security or the SAN setup. I need to figure out.

Regards,
Hui

-----Original Message-----
From: Otis Gospodnetic [mailto:otis_gospodnetic@yahoo.com] 
Sent: Thursday, May 13, 2004 6:51 AM
To: Lucene Users List
Subject: Re: index on SAN (storage area network)

My guess would be that you just have a wrong path to the index
directory somewhere.  You can add your own checks to your own code,
before you create IndexSearcher/Reader.

Something like:
if (new File(/path/to/your/index/dir).isDirectory()) - ok, else not ok
;)

Otis

--- hui <hui@triplehop.com> wrote:
> Hi,
> I am getting "not a directory" error when doing search after I moved
> the
> index from local to a SAN box. FSDirectory does not recognize the
> index
> directory as a directory. Any idea? I use JDK142 and Lucene 1.3
> final.
> 
> Creating the index works fine.
> 
> Regards,
> hui
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: lucene-user-help@jakarta.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-user-help@jakarta.apache.org


Mime
View raw message