lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reece.1247...@bloglines.com
Subject Re: Number query not working
Date Wed, 26 May 2004 23:25:40 GMT
Whoa!  I reread my last post and the last sentence didn't make much sense.
 This is what I meant to say:

"What is the SimpleAnalyzer doing to this
query to make it not work?"

--- Lucene Users List" <lucene-user@jakarta.apache.org
wrote:
Hi,
> 
> It looks like its because I'm using the SimpleAnalyzer
instead of the
> StandardAnalyzer.  What is the SimpleAnalyzer to this query
to make it not
> work?
> 
> Thanks,
> Reece
> 
> --- Lucene Users List"
<lucene-user@jakarta.apache.org
> wrote:
> Hi,
> > 
> > I have a bunch
of digits in a field.  When I do this search
> it returns
> > nothing:
> > 
> >   myField:0000001085609805100
> > 
> > It returns
> the correct
document
> > when I add a * to the end like this:
> > 
> >   myField:0000001085609805100*

> <--
> > added the *
> > 
> > I'm not sure what is happening here.  I'm
thinking
> that Lucene
> > is doing some number conversion internally when
it sees only
> digits.  When
> > I add the * maybe it presumes it is still
a string.  
> >
> 
> > How do I get a string
> > of digits to work without
adding a *?
> > 
> >
> Thanks,
> > Reece
> > 
> > ---------------------------------------------------------------------

> 
> > To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org

> > For
> additional commands, e-mail: lucene-user-help@jakarta.apache.org

> > 
> > 
> 
> 
> ---------------------------------------------------------------------

> To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
> For
additional commands, e-mail: lucene-user-help@jakarta.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: lucene-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: lucene-user-help@jakarta.apache.org


Mime
View raw message