lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Otis Gospodnetic <>
Subject Re: Why would a searcher not find an added document?
Date Thu, 22 May 2003 20:42:36 GMT

Close IndexWriter and open a new IndexReader/Searcher.
For some people lots of people asked this same question this week :)

Regarding the Swing app, yes, that would be nice to see, and if you
want to contribute it, we can put it in Lucene Sandbox.


--- Doug Kirk <> wrote:
> After deleting a document from the index, and then adding a document
> to 
> the index (same doc with updated info), it seems that the
> IndexSearcher 
> doesn't find the updated document.
> Whether I specify no limiting criteria (to find all docs), or
> specific 
> criteria to find just the doc I'm interested in, the new doc is never
> found. I'm not caching anything, so each time a search is done a new 
> IndexSearcher is created. Additionally, when I delete I use a new 
> IndexReader, and to add I use a new IndexWriter.
> I'm using 1.3-RC1, but the same issue occurs on 1.2.
> What the heck could I be doing wrong??
> P.S.  I know that the document is in the index, because I wrote a
> Swing 
> Lucene browser that lets me view the index and its docs using a 
> TreePane and an EditorPane (which I'd be happy to contribute if 
> somebody would like it).
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message