lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tian LUO <luotian_2...@yahoo.co.uk>
Subject System Requirements and Installation for Ant1.4
Date Wed, 04 Dec 2002 01:03:52 GMT

 
 

 

   Lucene runs with JDK 1.1 and later
   If you're working with the Lucene source, you'll need to use Ant 1.4 or greater Ant is
implemented in java and uses XML-based configuration files.  You can get it at: http://jakarta.apache.org/ant/index.html

   Specifically, you can get the binary distributions at:   http://jakarta.apache.org/builds/jakarta-ant/release/

   You'll need to download both the Ant binary distribution and the "optional" jar file. 
 
   Install these according to the instructions at:   http://jakarta.apache.org/ant/manual/index.html

 

Steps:

1)      Download Lucene from Apache http://jakarta.apache.org/builds/jakarta-lucene/release/


2)      Connect to the top-level of your Lucene installation. Lucene's top-level directory
contains the default.properties and build.xml files.  you do need to run ant from this location
so it knows where to find them. 

3)      Set ant in your PATH and ANT_HOME to the location of ant installation.

4)      Run ant by typing ‘ant’ at the command prompt.

In addition to these steps,what should I do to configure to make lucene

work properly with Ant1.4 ,thank u very much!

:)




---------------------------------
With Yahoo! Mail you can get a bigger mailbox -- choose a size that fits your needs

Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message