lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cox, Charlie" <c...@cincom.com>
Subject RE: Configuration in Standalone
Date Fri, 15 Nov 2002 14:14:27 GMT
the directory that you index should be 'webapps', not 'tomcat'. Tomcat will
only parse URLs under the webapps directory unless you configure it
otherwise.

in your browser, use the same url except remove '/webapps' and it should
show the page.

Charlie

> -----Original Message-----
> From: Uma Maheswar [mailto:uma@globalleafs.com]
> Sent: Friday, November 15, 2002 5:47 AM
> To: Lucene Users List
> Subject: Re: Configuration in Standalone
> 
> 
> Ok, I got it to work. I can now see a list of search results. 
> But when I
> click on the links in those search results, I get that  the 
> file is not
> found. It has this URL
> http://localhost:8080/webapps/tomcat-docs/catalina/docs/api/or
> g/apache/catal
> ina/deploy/Test.html
> 
> I dont even see http://localhost:8080/webapps is working 
> either. What could
> be the problem?
> 
> Uma
> 
> 
> ----- Original Message -----
> From: "Spence Nichols" <spence_nichols@yahoo.co.uk>
> To: "Lucene Users List" <lucene-user@jakarta.apache.org>
> Sent: Friday, November 15, 2002 3:40 PM
> Subject: RE: Configuration in Standalone
> 
> 
> > The index location specified in the configuration file must 
> be the same as
> > that specified for the -index parameter when running 
> IndexHTML .  Use an
> > absolute path for both to make sure its looking at the same 
> location.
> >
> > Looks like you may need to restart Tomcat to see your new
> configuration.jsp
> > file.
> >   -----Original Message-----
> >   From: Uma Maheswar [mailto:uma@globalleafs.com]
> >   Sent: 15 November 2002 09:37
> >   To: Lucene Users List
> >   Subject: Configuration in Standalone
> >
> >
> >   Hello,
> >   I am trying to do search for Standalone. I made it up to 
> configuration
> > level. All is working well. But when I try to search in
> >   http://localhost:8080/luceneweb/index.jsp , I get
> >   Welcome to the Lucene Template application. (This is the header)
> >
> >   ERROR opening the Index - contact sysadmin!
> >
> >   While parsing query: C:\opt\lucene\index not a directory
> >
> >
> >   Jakarta Lucene Template WebApp 1.0
> >
> >   These are the steps that I have followed
> >
> >
> >   C:\Progra~1\Apache Tomcat 4.0\java
> > org.apache.lucene.demo.IndexHTML -create -index mysearch ..
> >   I got a directory named "mysearch" in c:\Progra~1\Apache Tomcat
> > 4.0\mysearch
> >   I got a direcotory named "luceneweb" in 
> tomcat\webapps\luceneweb after
> > copying luceneweb.war file to tomcat/webapps
> >
> >    I have already configured the configuration.jsp and made 
> changes to
> > indexLocation as C:\\Program~1\ApacheTomcat 4.0\mysearch; I 
> am attaching
> my
> > configuration.jsp for your review.
> >
> >   I updated my .war file too. But why am I getting this error?
> >
> >   Thanks
> >   Uma
> >   http://www.javagalaxy.com
> >
> 
> 
> --
> To unsubscribe, e-mail:   
<mailto:lucene-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:lucene-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:lucene-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:lucene-user-help@jakarta.apache.org>


Mime
View raw message