lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From karl øie <k...@gan.no>
Subject Re: Multithread searching problem on Linux
Date Tue, 01 Oct 2002 16:55:04 GMT
Try to run your vm in classic mode "java -classic" to disable the 
hotspot features...

mvh karl øie


On tirsdag, okt 1, 2002, at 18:16 Europe/Oslo, Stas Chetvertkov wrote:

> Hi All,
>
> I am building a search engine based on Lucene. Recently I created a 
> test
> simulating multiple users searching in the same index simultaneously 
> and
> found out that quite often JVM crashes with 'Hotspot Virtual Machine 
> Error :
> 11'. I couldnot reproduce this bug on Windows box, but observed it a 
> lot on
> Red Hat Linux 7.3 with different versions of Sun's 1.3 JVM, including 
> the
> most recent one (1.3.1_04 at the moment).
>
> I am attaching a simple test that generates hotspot error in 90% of 
> cases.
> In our code we have to create new IndexSearcher for every search 
> because
> indices are updated in real time.
>
> The only workaround I found for this problem so far is reducing the 
> number
> of searching threads which doesnot seem to be a good solution.
>
> Had anyone encountered problems like this one?
>
> Regards,
> Stas.
> <SearchTest.java>--
> To unsubscribe, e-mail:   
> <mailto:lucene-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: 
> <mailto:lucene-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:lucene-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:lucene-user-help@jakarta.apache.org>


Mime
View raw message