lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Rozee <r...@gdse.com>
Subject Re: 3 Times Isn't a Charm for me and Lucene
Date Fri, 03 May 2002 13:05:55 GMT
Thanks for responding.  I wrote my message in panic mode so I left out
some vital information.  The servlet works for three queries and then
causes Tomcat to produce this error in its log file:

2002-05-03 09:35:08 org.apache.catalina.INVOKER.gdse.search: init
2002-05-03 09:47:47 org.apache.catalina.INVOKER.gdse.search:
/servlet/gdse.search: org.apache.velocity.exception.ResourceNotF
oundException: Unable to find resource 'templates/gdse/main.vm'
2002-05-03 09:47:50 WebappLoader[] Error tracking modifications
java.lang.NullPointerException
        at java.util.Arrays.sort(Arrays.java:1073)
        at
org.apache.naming.resources.FileDirContext.list(FileDirContext.java:895)
        at
org.apache.naming.resources.FileDirContext.listBindings(FileDirContext.java:354)
        at
org.apache.naming.resources.ProxyDirContext.listBindings(ProxyDirContext.java:479)
        at
org.apache.catalina.loader.WebappClassLoader.modified(WebappClassLoader.java:798)
        at
org.apache.catalina.loader.WebappLoader.run(WebappLoader.java:1272)
        at java.lang.Thread.run(Thread.java:536)

After that I have to reboot my server.  It is claiming it is a Velocity
problem but I have not had this appear before.  Yet when I started to use
Lucene, I get this weird error. All of my other servlets seem to be
working fine, however, they have not been tested under any simulated load 
yet.

I tried to pattern my code after the demo but I may be missing something.  
If you want to see the code, let me know.  Any guesses as to whether I
should be talking with Velocity or with you guys for this problem? Thanks.

James

*********************************************************
The Game Development Search Engine
and DQuest E-zine
http://www.gdse.com/

A Member of the Future Games Network
http://www.fgn.com/


On Thu, 2 May 2002, Otis Gospodnetic wrote:

> Uh, this is a very broad question.
> A number of things could be wrong.
> Look at your Tomcat log files.
> Write a class that you can run from the command line, not as a servlet,
> that may be easier to debug.  You can use one of the demo ones to get
> started.
> Log things, don't catch exceptions and ignore them, etc.
> Check that your index directory exists, that it is readable by the user
> doing the searchs, etc. etc.
> 
> Otis
> 
> --- James Rozee <root@gdse.com> wrote:
> > I've just recently recoded my entire website and search engine to use
> > Tomcat 4.0.3, Velocity, MySQL and Lucene 1.2-rc4.  I have been using
> > MySQL
> > and servlets for a few years now.  However, I only recently started
> > using
> > Lucene.  I've built a Lucene index from my document collection and
> > now I
> > need to be able to search it from a servlet.
> > 
> > My first attempt to do this causes Tomcat to return a page that is
> > empty.
> > Can anyone give me some advice on how to track down my problem?  My
> > hardware is an SS1000E with 5 SM81s and 1.2GB RAM.  Thanks.
> > 
> > James
> > 
> > *********************************************************
> > The Game Development Search Engine
> > and DQuest E-zine
> > http://www.gdse.com/
> > 
> > A Member of the Future Games Network
> > http://www.fgn.com/
> > 
> > 
> > 
> > --
> > To unsubscribe, e-mail:  
> > <mailto:lucene-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
> > <mailto:lucene-user-help@jakarta.apache.org>
> > 
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Health - your guide to health and wellness
> http://health.yahoo.com
> 
> 


--
To unsubscribe, e-mail:   <mailto:lucene-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:lucene-user-help@jakarta.apache.org>


Mime
View raw message