lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Trevor Boicey <tboi...@brit.ca>
Subject Re: 3 Times Isn't a Charm for me and Lucene
Date Thu, 02 May 2002 23:15:47 GMT
James Rozee wrote:
> 
> I've just recently recoded my entire website and search engine to use
> Tomcat 4.0.3, Velocity, MySQL and Lucene 1.2-rc4.  I have been using MySQL
> and servlets for a few years now.  However, I only recently started using
> Lucene.  I've built a Lucene index from my document collection and now I
> need to be able to search it from a servlet.
> 
> My first attempt to do this causes Tomcat to return a page that is empty.
> Can anyone give me some advice on how to track down my problem?  My
> hardware is an SS1000E with 5 SM81s and 1.2GB RAM.  Thanks.

  Empty page from Tomcat often means that you are generating
an exception or smoething and the page is dying, but
you don't get very good debug information or output because
of output buffering and such, so where the page is dying isn't
clear from what you get.

  Put some more try {} sections in your dangerous code, and see
if you can get more info. Also try commenting in and out a few sections
at a time and see what you can find.

-- 
Trevor Boicey, P. Eng.
Ottawa, Canada, tboicey@brit.ca
ICQ #17432933 http://www.brit.ca/~tboicey/
"Is this cool or not, I can't tell?" - Eric Cartman

--
To unsubscribe, e-mail:   <mailto:lucene-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:lucene-user-help@jakarta.apache.org>


Mime
View raw message