lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralf Hettesheimer" <hetteshei...@cms.tecmath.com>
Subject Wildcard query problem with "?"
Date Thu, 18 Apr 2002 08:11:34 GMT
Hello,

I have been using RC2 until yesterday when I tried the latest nightly build.
Now it seems that I can no longer search for wildcard-queries with a
question mark.
For example in my index there are two documents, one containing the word
"meier" and another one containing the word "maier". With RC2 I could search
for "m?ier" and got two hits. With anything later (I tried RC3, RC4 and the
nightly builds from 1704 and 1804) I get 0 hits. When searching for "mei?r"
the same, 1 hit with RC2 and 0 hits with RC4.
The QueryParser from RC2 generated a BooleanQuery and the QueryParser from
RC4 generates a PhraseQuery. I have attached the source code of a little
test program and output from the debugger.
Could somebody explain this behaviour?

Thanks
Ralf Hettesheimer



Mime
View raw message