lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "New, Cecil (GEAE)" <cecil....@ae.ge.com>
Subject RE: Attribute Search
Date Mon, 26 Nov 2001 22:04:07 GMT
this is exactly what I was doing.  Store=false, index=true, and token=false.

This combination is *not* represented by one of the factory methods.  It
appeared to work ok, but searches *never* returned any hits.

That's why I suspect it is a bug.

-----Original Message-----
From: Ype Kingma [mailto:ykingma@xs4all.nl]
Sent: Wednesday, November 21, 2001 2:51 PM
To: Lucene Users List
Subject: Re: Attribute Search


Paula,

>I came across a tutorial which had some details on the static factory Field
>methods.  But none of the factory methods return a Field object with the
>following settings:
>Store => false
>Index => true
>Tokenize => false
>
>I'm beginning to think this is a bug - that this combination is handled
>correctly.

The Field() constructor is public, can't you use that instead of one
of the factory methods?

public Field(String name,
             String string,
             boolean store,
             boolean index,
             boolean token)

Regards,
Ype

--
To unsubscribe, e-mail:
<mailto:lucene-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:lucene-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:lucene-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:lucene-user-help@jakarta.apache.org>


Mime
View raw message