lucene-java-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From uschind...@apache.org
Subject svn commit: r881315 - in /lucene/java/trunk/src/java/org/apache/lucene/analysis/standard: READ_BEFORE_REGENERATING.txt StandardTokenizerImpl.java StandardTokenizerImpl.jflex
Date Tue, 17 Nov 2009 14:59:42 GMT
Author: uschindler
Date: Tue Nov 17 14:59:42 2009
New Revision: 881315

URL: http://svn.apache.org/viewvc?rev=881315&view=rev
Log:
LUCENE-2074: First step until we resolve this issue. This just adds the warning, also added
to 3.0. We will update the Flex version to 1.5 resolve this in 3.1.

Added:
    lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/READ_BEFORE_REGENERATING.txt
  (with props)
Modified:
    lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/StandardTokenizerImpl.java
    lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/StandardTokenizerImpl.jflex

Added: lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/READ_BEFORE_REGENERATING.txt
URL: http://svn.apache.org/viewvc/lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/READ_BEFORE_REGENERATING.txt?rev=881315&view=auto
==============================================================================
--- lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/READ_BEFORE_REGENERATING.txt
(added)
+++ lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/READ_BEFORE_REGENERATING.txt
Tue Nov 17 14:59:42 2009
@@ -0,0 +1,7 @@
+WARNING: if you change StandardTokenizerImpl.jflex and need to regenerate
+      the tokenizer, only use Java 1.4 !!!
+      This grammar currently uses constructs (eg :digit:, :letter:) whose 
+      meaning can vary according to the JRE used to run jflex.  See
+      https://issues.apache.org/jira/browse/LUCENE-1126 for details.
+      For current backwards compatibility it is needed to support
+      only Java 1.4 - this will change in Lucene 3.1.

Propchange: lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/READ_BEFORE_REGENERATING.txt
------------------------------------------------------------------------------
    svn:eol-style = native

Propchange: lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/READ_BEFORE_REGENERATING.txt
------------------------------------------------------------------------------
    svn:keywords = Date Author Id Revision HeadURL

Modified: lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/StandardTokenizerImpl.java
URL: http://svn.apache.org/viewvc/lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/StandardTokenizerImpl.java?rev=881315&r1=881314&r2=881315&view=diff
==============================================================================
--- lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/StandardTokenizerImpl.java
(original)
+++ lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/StandardTokenizerImpl.java
Tue Nov 17 14:59:42 2009
@@ -21,11 +21,13 @@
 
 /*
 
-NOTE: if you change this file and need to regenerate the tokenizer,
-      remember to use JRE 1.4 when running jflex (before Lucene 3.0).
-      This grammar now uses constructs (eg :digit:) whose meaning can
-      vary according to the JRE used to run jflex.  See
-      https://issues.apache.org/jira/browse/LUCENE-1126 for details
+WARNING: if you change StandardTokenizerImpl.jflex and need to regenerate
+      the tokenizer, only use Java 1.4 !!!
+      This grammar currently uses constructs (eg :digit:, :letter:) whose 
+      meaning can vary according to the JRE used to run jflex.  See
+      https://issues.apache.org/jira/browse/LUCENE-1126 for details.
+      For current backwards compatibility it is needed to support
+      only Java 1.4 - this will change in Lucene 3.1.
 
 */
 

Modified: lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/StandardTokenizerImpl.jflex
URL: http://svn.apache.org/viewvc/lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/StandardTokenizerImpl.jflex?rev=881315&r1=881314&r2=881315&view=diff
==============================================================================
--- lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/StandardTokenizerImpl.jflex
(original)
+++ lucene/java/trunk/src/java/org/apache/lucene/analysis/standard/StandardTokenizerImpl.jflex
Tue Nov 17 14:59:42 2009
@@ -19,12 +19,13 @@
 
 /*
 
-NOTE: if you change StandardTokenizerImpl.jflex and need to regenerate
-      the tokenizer, remember to use JRE 1.4 to run jflex (before
-      Lucene 3.0).  This grammar now uses constructs (eg :digit:,
-      :letter:) whose meaning can vary according to the JRE used to
-      run jflex.  See
+WARNING: if you change StandardTokenizerImpl.jflex and need to regenerate
+      the tokenizer, only use Java 1.4 !!!
+      This grammar currently uses constructs (eg :digit:, :letter:) whose 
+      meaning can vary according to the JRE used to run jflex.  See
       https://issues.apache.org/jira/browse/LUCENE-1126 for details.
+      For current backwards compatibility it is needed to support
+      only Java 1.4 - this will change in Lucene 3.1.
 
 */
 



Mime
View raw message