lucene-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler" <...@thetaphi.de>
Subject RE: Java version set to 1.8 for SOLR 6.4.0
Date Mon, 13 Feb 2017 10:57:30 GMT
Hi,

SOLR_JAVA_HOME must point to the directory of the JDK, not the "java" command:

SOLR_JAVA_HOME = "/opt/wml/jdk1.8.0_66"

Uwe

-----
Uwe Schindler
Achterdiek 19, D-28357 Bremen
http://www.thetaphi.de
eMail: uwe@thetaphi.de

> -----Original Message-----
> From: Uchit Patel [mailto:uchitspatel@yahoo.com.INVALID]
> Sent: Monday, February 13, 2017 11:14 AM
> To: general@lucene.apache.org; solr-user@lucene.apache.org;
> jan.asf@cominvent.com
> Subject: Re: Java version set to 1.8 for SOLR 6.4.0
> 
> 
> I have updated SOLR_JAVA_HOME in following file.
> /opt/wml/solr-6.4.0/bin/solr.in.sh
> SOLR_JAVA_HOME = "/opt/wml/jdk1.8.0_66/jre/bin/java"
> But it is not working.
> Regards,
> Uchit Patel
> I have installed SOLR 6.4.0 on Linux box. I have Java 1.7.0 and 1.8.0 both on
> the box. By default it point to 1.7.0. Some other applications using 1.7.0 Java.
> I want to set Java 1.8.0 only for SOLR 6.4.0. What should I need to update for
> only SOLR 6.4.0 to hit Java 1.8.0. I don't want to remove Java 1.7.0 because
> some other applications using Java 1.7.0.
> Thanks.
> Regards,
> Uchit Patel
> 
>       From: Uchit Patel <uchitspatel@yahoo.com>
>  To: "general@lucene.apache.org" <general@lucene.apache.org>; "solr-
> user@lucene.apache.org" <solr-user@lucene.apache.org>;
> "jan.asf@cominvent.com" <jan.asf@cominvent.com>
>  Sent: Monday, February 13, 2017 3:38 PM
>  Subject: Re: Java version set to 1.8 for SOLR 6.4.0
> 
> Hi ,
> I tried SOLR_JAVA_HOME = "/opt/wml/jdk1.8.0_66/jre/bin/java" but it is not
> working.
> Regards,
> Uchit Patel
> I have installed SOLR 6.4.0 on Linux box. I have Java 1.7.0 and 1.8.0 both on
> the box. By default it point to 1.7.0. Some other applications using 1.7.0 Java.
> I want to set Java 1.8.0 only for SOLR 6.4.0. What should I need to update for
> only SOLR 6.4.0 to hit Java 1.8.0. I don't want to remove Java 1.7.0 because
> some other applications using Java 1.7.0.
> Thanks.
> Regards,
> Uchit Patel
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 


Mime
View raw message