lucene-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Wang <>
Subject Re: CLue - lucene command line - questions
Date Fri, 24 May 2013 15:22:16 GMT
Thanks Issac.

1. readonly support is a great idea. I did exactly what you suggested and
also added readonly toggle. Please pull latest from github and rebuild.

2. did you try to jar with all the dependencies bundled? Clue is built with
lucene 4.3.0, so the default codec should work. If there is not a default
codec, I think you need to some special classpath trick: e.g. edit
in the bin directly and set the classpath accordingly.



On Fri, May 24, 2013 at 4:14 AM, Isaac Hebsh <> wrote:

> Hi, I have some questions about CLue. I cloud not find the original
> message, so I'm sorry for opening a new thread.
> 1. It seems that IndexWriter is opened on every run of CLue. Probaby it
> happens due to MERGE and DELETE commands. But there are many other
> commands, which does not require any write operation. When tryng to use
> CLue on an active index (eg. a running core of Solr), it fails because of
> the write lock. I think it will be better to create an IndexWriter only
> when it is really needed.
> 2. I've tried to use CLue on an index of LUCENE_43 codec. CLue failed. it
> says that a need to set classpath to the the folder of the relevant JARs. I
> did that, but it didnt solve the issue.
> It looks like a very nice and usefull tool :)

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message