lucene-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Alyea <dal...@gmail.com>
Subject Lucene and Solr installation problems
Date Sat, 10 Nov 2012 17:49:09 GMT
I can't seem to get lucene or solr running on my server.
I am trying for 3.6.1 since my server has java 1.5.  Here is
info about my server:

<Q>$ cat /etc/*rel*
CentOS release 6.3 (Final)
CentOS release 6.3 (Final)
CentOS release 6.3 (Final)
cpe:/o:centos:linux:6:GA

<Q>$ java -version
java version "1.5.0"
gij (GNU libgcj) version 4.4.6 20120305 (Red Hat 4.4.6-4)

Here is CLASSPATH:

<Q>$ env | grep CLASSPATH
CLASSPATH=/home/site/lucene-3.6.1/lucene-core-3.6.1.jar:/home/site/lucene-3.6.1/contrib/demo/lucene-demo-3.6.1.jar

The files:

<Q>$ ls -l /home/site/lucene-3.6.1/lucene-core-3.6.1.jar
-rw-r--r-- 1 site site 1537988 Jul 17 12:36
/home/site/lucene-3.6.1/lucene-core-3.6.1.jar
<Q>$ ls -l /home/site/lucene-3.6.1/contrib/demo/lucene-demo-3.6.1.jar
-rw-r--r-- 1 site site 16854 Jul 17 12:38
/home/site/lucene-3.6.1/contrib/demo/lucene-demo-3.6.1.jar

Working in:

<Q>$ pwd
/home/site/lucene-3.6.1

When I try the tutorial demo, I get:

<Q>$ java org.apache.lucene.demo.IndexFiles -docs contrib/demo/src
Indexing to directory 'index'...
Exception in thread "main" java.lang.ExceptionInInitializerError
   at java.lang.Class.initializeClass(libgcj.so.10)
   at
org.apache.lucene.index.IndexWriterConfig.<init>(IndexWriterConfig.java:151)
   at org.apache.lucene.demo.IndexFiles.main(IndexFiles.java:89)
Caused by: java.lang.NullPointerException
   at java.lang.ref.Reference.<init>(libgcj.so.10)
   at java.lang.ref.WeakReference.<init>(libgcj.so.10)
   at
org.apache.lucene.util.WeakIdentityMap$IdentityWeakReference.<init>(WeakIdentityMap.java:180)
   at org.apache.lucene.util.WeakIdentityMap.get(WeakIdentityMap.java:80)
   at
org.apache.lucene.util.VirtualMethod.getImplementationDistance(VirtualMethod.java:95)
   at
org.apache.lucene.util.VirtualMethod.compareImplementationDistance(VirtualMethod.java:146)
   at org.apache.lucene.search.Similarity.<init>(Similarity.java:538)
   at
org.apache.lucene.search.DefaultSimilarity.<init>(DefaultSimilarity.java:23)
   at org.apache.lucene.search.Similarity.<clinit>(Similarity.java:544)
   at java.lang.Class.initializeClass(libgcj.so.10)
   ...2 more

Any ideas why lucene won't run on my server?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message