lucene-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "joshan.mahmud" <joshan.mah...@gmail.com>
Subject Unable to search a single term 'calligraphy'
Date Mon, 26 Mar 2012 13:54:07 GMT
Hi all

I'm having a strange issue whereby:

I am indexing a set of terms (which is used as a taxonomy) and there is a
term that I cannot find.  The term is 'calligraphy'.  It is being put into
the index as TOKENIZED (we're using Lucene.NET 2.9.2 - which has deprecated
TOKENIZED) but seems to be working in general.  The field is TOKENIZED as
terms such as 'calligraphy-board' or 'calligraphy-tool' can appear. 
However, whenever a search is done (using StandardAnalyzer or
KeywordAnalyzer) no documents including the term 'calligraphy' ever returns.

The lucene query we're using is just: term:calligraphy

There are some other terms we have which is exhibiting the same issue such
as term:cooking.

However, we have a term 'vessel' which is indexed exactly the same way, and
there are other terms such as 'food-vessel' or 'whistling vessel' and
doesn't exhibit this issue.  This term has been indexed in exactly the same
way (the same code is being used).  We cannot seem to figure out what
difference there is and was wondering whether anyone else have experienced
similar issues.

Any advice would be greatly appreciated!

Thanks
Joshan




--
View this message in context: http://lucene.472066.n3.nabble.com/Unable-to-search-a-single-term-calligraphy-tp3858186p3858186.html
Sent from the Lucene - General mailing list archive at Nabble.com.

Mime
View raw message