lucene-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From surinekkalapu <surinekkal...@yahoo.com>
Subject Re: DIH Delta Import not working
Date Fri, 30 Sep 2011 15:58:10 GMT
Yes, I have unique key configured in the schema.xml. I tried both the ways as
described below. Unfortunately, I could not get the delta indexing worked in
both ways. The corresponding database table name is Documents. I am updating
the document title in this table for given document id (ID). In my first
post you can see that ID is defined as pk (primary key).

Scenario 1.

schemal.xml snippet.
     ..........
        <field name="ID" type="string" indexed="true" stored="true"
multiValued="false"/>
        <field name="DocumentNumber" type="string" indexed="true"
stored="true" multiValued="false"/>
        <field name="DocumentTitle" type="string" indexed="true"
stored="true" multiValued="false"/>
        <field name="UKNUMGEN" type="string" indexed="true" stored="false"
multiValued="false"/>
     ........
       <uniqueKey>UKNUMGEN</uniqueKey>
     ...........

Scenario 2.

     ..........
        <field name="ID" type="string" indexed="true" stored="true"
multiValued="false"/>
        <field name="DocumentNumber" type="string" indexed="true"
stored="true" multiValued="false"/>
        <field name="DocumentTitle" type="string" indexed="true"
stored="true" multiValued="false"/>
        <field name="UKNUMGEN" type="string" indexed="true" stored="false"
multiValued="false"/>
     ........
       <uniqueKey>ID</uniqueKey>
     ...........



--
View this message in context: http://lucene.472066.n3.nabble.com/DIH-Delta-Import-not-working-tp3377360p3382861.html
Sent from the Lucene - General mailing list archive at Nabble.com.

Mime
View raw message