lucene-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ntsrikanth <ntsrika...@gmail.com>
Subject Re: Index creation from multiple data sources
Date Mon, 19 Sep 2011 13:47:07 GMT

Hi Ted,

After little struggle figured out a way of joining xml files with database.
But for some reason it is not working. After the import, only the content
from xml is present in my index. Msql contents are missing.

To debug, I replaced the parametrized query with a simple select statement
and it worked well. As a next step, I purposefully created a syntax error in
the sql and tried again. This time the import failed as expected printing
the values in the log file.

What I found interesting is all the values eg. brochure_id are substituted
in the query by a enclosing square brackets. for example:   *and brochure_id
= '[55]'*

I have the following in the schema.xml
    
    613    
    614    


And my data configuration:


dataconfig.xml
----------------------
<?xml version="1.0" encoding="UTF-8"?>

     

    
    
        
            
               
               
               
               

               

                    
            
        
    



Any idea why I am getting this weird substitution ?

Thanks,
Srikanth


--
View this message in context: http://lucene.472066.n3.nabble.com/Index-creation-from-multiple-data-sources-tp3338344p3348603.html
Sent from the Lucene - General mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message