lucene-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Hatcher <erik.hatc...@gmail.com>
Subject Re: Error deploying solr.war into Jboss7
Date Wed, 17 Aug 2011 20:36:25 GMT
For the record, I'm starting work now on moving the Velocity response writer back to a contrib
module so these dependencies won't be embedded in the WAR file (after I make the commit this
week some time, most likely).

	Erik

On Aug 17, 2011, at 15:35 , Chris Hostetter wrote:

> 
> : Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException:
> : failed to process
> : "/opt/jboss-as-web-7.0.0.Final/standalone/deployments/solr.war/WEB-INF/lib/velocity-tools-2.0.jar"
> 	...
> : Caused by: java.util.zip.ZipException: error in opening zip file
> :           at java.util.zip.ZipFile.open(Native Method) [:1.6.0_26]
> 
> That's weird.
> 
> : The only way I found that I could deploy the solr.war was to remove the
> : velocity-tools-2.0.jar from the solr.war/WEB-INF/lib directory.
> : I am not sure this is the right fix.  Should this be reported as a bug to
> : SOLR or to jBoss?
> : I have already posted this error to the jBoss community forum.
> 
> have you tried inspecting that velocity-tools-2.0.jar file with the "jar" 
> tool, or a regular zip program to see if there is infact a problem with 
> it?  did it get corrupted somehow?  does it match what you find if you 
> manually extract that file directly from the solr.war?
> 
> PS: please send replies to the solr-user@lucene mailing list instead of 
> general@lucene ... it is more appropriate for this type of question.
> 
> 
> 
> -Hoss


Mime
View raw message