lucene-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sair <sai_ratnapar...@yahoo.com>
Subject Problem creating mahout vectors from solr index
Date Thu, 11 Aug 2011 19:19:00 GMT
I have solr version 1.4.1 and mahout version 0.4 
I have created index from the xml files given in exampledocs directory. It
is working fine. Queries are also working on those indexes. But when I'm
trying to create mahout vectors from the solr index it is giving message
wrote: 0 vectors
Is there any configuration settings I'm missing?

This is the output I'm getting:
hadoop@dahlia:/home/sai/project/mahout-distribution-0.4$ bin/mahout
lucene.vector --dir
/home/sai/project/apache-solr-1.4.1/example/solr/data/index/ --output
/home/sai/project/output/part-out.vec --field title-clustering --idField id
--dictOut /home/sai/project/output/dict.out --norm 2
Running on hadoop, using HADOOP_HOME=/usr/local/hadoop
HADOOP_CONF_DIR=/usr/local/hadoop/conf
11/08/11 14:55:15 INFO lucene.Driver: Output File:
/home/sai/project/output/part-out.vec
11/08/11 14:55:16 INFO util.NativeCodeLoader: Loaded the native-hadoop
library
11/08/11 14:55:16 INFO zlib.ZlibFactory: Successfully loaded & initialized
native-zlib library
11/08/11 14:55:16 INFO compress.CodecPool: Got brand-new compressor
11/08/11 14:55:16 INFO lucene.Driver: Wrote: 0 vectors
11/08/11 14:55:16 INFO lucene.Driver: Dictionary Output file:
/home/sai/project/output/dict.out
11/08/11 14:55:16 INFO driver.MahoutDriver: Program took 1078 ms


sai    


--
View this message in context: http://lucene.472066.n3.nabble.com/Problem-creating-mahout-vectors-from-solr-index-tp3247141p3247141.html
Sent from the Lucene - General mailing list archive at Nabble.com.

Mime
View raw message