lucene-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andi Vajda <va...@apache.org>
Subject Re: [VOTE] Release of Apache Lucene 3.0.3 and 2.9.4 artifacts (take 2)
Date Sun, 28 Nov 2010 23:56:02 GMT

On Mon, 29 Nov 2010, Uwe Schindler wrote:

> The problem you mentioned is there since ages? I don't really understand 
> the implication for the artifacts to vote on?

Well, it's the first time I noticed and it makes building on Windows/Cygwin 
broken as the MANIFEST.MF file is invalid and the build then fails.

Note that I did not vote against the artifacts, I just reported a problem I 
just saw and spent an hour working around.

Andi..

>
> Uwe
>
>
>
> "Andi Vajda" <vajda@apache.org> schrieb:
>
>>
>> On Sun, 28 Nov 2010, Uwe Schindler wrote:
>>
>>> Hi all Lucene Java committers and PMC,
>>>
>>> As Robert found some test problems in the last release artifacts, I
>> have
>>> posted a release candidate for both Apache Lucene Java 2.9.4 and
>>> 3.0.3 (which both have the same bug fix level, functionality and
>> release
>>> announcement), built from revision 1039909 of the corresponding
>> branches.
>>
>> As I was trying to build PyLucene 2.9.4 with Lucene 2.9.4 on Windows 7
>> with
>> Cygwin (the usual Windows setup), I found a problem with building
>> Lucene
>> Core 2.9.4. The ${svnversion} trickery to run the svnversion executable
>> from
>> ant in common-build.xml produces an invalid MANIFEST.MF file as follows
>>
>> (note extra lines of garbage for "Implementation Version"):
>>
>>   Manifest-Version: 1.0
>>   Ant-Version: Apache Ant 1.7.0
>>   Created-By: 17.1-b03 (Sun Microsystems Inc.)
>>   Specification-Title: Lucene Search Engine: core
>>   Specification-Version: 2.9.4
>>   Specification-Vendor: The Apache Software Foundation
>>   Implementation-Title: org.apache.lucene
>> Implementation-Version: 2.9.4       1 [main] svnversion 2956 tty_list:
>>    :allocate: No tty allocated
>>   exported - 2010-11-28 15:26:12
>>   Implementation-Vendor: The Apache Software Foundation
>>   X-Compile-Source-JDK: 1.4
>>   X-Compile-Target-JDK: 1.4
>>
>> Adding a -Dsvnversion=exported to the ant command line works around the
>>
>> problem.
>>
>> Andi..
>>
>>> Thanks for all your help! Please test them and give your votes, the
>>> scheduled release date for both versions will be Friday, December
>> 3th, 2010.
>>> Only votes from the Lucene PMC are binding, but everyone is welcome
>> to check
>>> the release candidate and voice their approval or disapproval. The
>> vote
>>> passes if at least three binding +1 votes are cast.
>>>
>>> We planned the parallel release with one announcement because of
>> their
>>> parallel development / bug fix level to emphasize that they are equal
>> except
>>> deprecation removal and Java 5 since major version 3. I will post the
>>> possible release announcement soon for corrections.
>>>
>>> Artifacts (incl. Maven) and Changes.txt can be found here:
>>> http://s.apache.org/fL
>>>
>>> Attached you will also find a cool ANT build script that can patch a
>> Solr
>>> 1.4.1 distribution to use Lucene 2.9.4:
>>>
>>> - Extract the binary Lucene distribution artifact: lucene-2.9.4.zip
>> (not
>>> -src.zip a svn checkout!)
>>> - Place the attached patch-solr.xml file in the extracted Lucene
>>> distribution's root folder
>>> - Execute:
>>> 	ant -f patch-solr.xml -Dsolr.dir=/path/to/Solr-1.4.1-distibution
>>>
>>> After that you have a patched Solr, with updated lib/ folder and
>> updated war
>>> files in dist/ and example/webapps/.
>>>
>>> -----
>>> Uwe Schindler
>>> H.-H.-Meier-Allee 63, D-28213 Bremen
>>> http://www.thetaphi.de
>>> eMail: uwe@thetaphi.de
>>>
>>>
>>>
>
> --
> Uwe Schindler
> H.-H.-Meier-Allee 63, 28213 Bremen
> http://www.thetaphi.de
>

Mime
View raw message