lucene-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grant Ingersoll <gsing...@apache.org>
Subject Re: Lucene index compatibility
Date Thu, 28 Jan 2010 13:55:05 GMT

On Jan 28, 2010, at 6:03 AM, kumarlimbu wrote:

> 
> Hi Everyone,
> 
> We are currently using Lucene 1.9. We want to upgrade our application from
> 1.9 to 2.9. The reasons for upgrade is we want to get better performance. 
> 
> What we are unsure of is whether a Lucene index created using version 1.9
> will be compatible with a new application built using lucene 2.9? Are they
> compatible or we are required to recreate the index again with the newer
> version of Lucene.

I doubt anyone has tried this, so your best bet will be to test it.  It is probably more likely
to be successful if you can go from 1.9->2.0 ->2.9, but even that isn't a guarantee
depending on some of the back compatibility breaks that have occurred.

How hard would it be to simply re-index?

> 
> Thanks in advance.
> -- 
> View this message in context: http://old.nabble.com/Lucene-index-compatibility-tp27354221p27354221.html
> Sent from the Lucene - General mailing list archive at Nabble.com.
> 

--------------------------
Grant Ingersoll
http://www.lucidimagination.com/

Search the Lucene ecosystem using Solr/Lucene: http://www.lucidimagination.com/search


Mime
View raw message