lucene-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gasi" <g...@artentis.com>
Subject Re: lucene webdemo on a webhosting hosting account
Date Fri, 02 Sep 2005 18:37:30 GMT
Erik,

I understand this but I hoped that somebody else had the same problem like 
me an perhaps you could know a solution.

Thank you for your time

Greetings


Gaston
----- Original Message ----- 
From: "Erik Hatcher" <erik@ehatchersolutions.com>
To: <general@lucene.apache.org>
Sent: Friday, September 02, 2005 6:08 PM
Subject: Re: lucene webdemo on a webhosting hosting account


> Gaston,
>
> At this point there is nothing further I can do to help.  It works on
> your local environment, but not on your 3rd party hosting
> environment.  Therefore the difference must be environment related.
> It certainly is not a Lucene issue.
>
>     Erik
>
>
> On Sep 2, 2005, at 11:30 AM, Gasi wrote:
>
>> Hi Erik,
>>
>> one user asked me to send him my webstructure, because  he has your
>> webdemo
>> and it works perfect. And he said that it worked when these jars
>> where in
>> the same directory as results.jsp. 'delateable' is a typo. I have
>> uploaded
>> the same files that have worked on my laptop with jakarta-
>> tomcat-3.3.2 on
>> the webserver. And I have chnaged the diretory in the
>> configuration.jsp
>> file. And the webindex is found, has a size of 1,3MB and for every
>> search he
>> delivers null results.
>> I think that I have done everything allright and it should work,
>> but it does
>> not. so now I am trying exotical solutions because I have thought
>> about all
>> possible errors. I am ignoring Murphy's Laws at this time ;-)
>>
>> Another User wrote to me that he has the same problem.
>>
>> I try much and for 4 days now and it still doesn' work.
>>
>> Greetings
>>
>>
>> Gaston
>> ----- Original Message -----
>> From: "Erik Hatcher" <erik@ehatchersolutions.com>
>> To: <general@lucene.apache.org>
>> Sent: Friday, September 02, 2005 11:50 AM
>> Subject: Re: lucene webdemo on a webhosting hosting account
>>
>>
>>
>>>
>>> On Sep 1, 2005, at 6:08 PM, Gasi wrote:
>>>
>>>> I putted these both jar files in the same diretory as results.jsp
>>>> but I
>>>> still don't have any results.
>>>> The struture is:
>>>> everything is in a folder called luceneweb
>>>> +luceneweb
>>>>     +META-INF
>>>>     +WEB-INF
>>>>     +webindex
>>>>    +configuration.jsp
>>>>    +footer.jsp
>>>>    +header.jsp
>>>>    +index.jsp
>>>>    +lucene-1.4.3.jar
>>>>    +lucene-demos-1.4.3.jar
>>>>    +results.jsp
>>>>
>>>
>>> This is off-topic for this list to discuss WAR directory structure.
>>> JAR files *must* go in WEB-INF/lib.  Please read up on this
>>> structure.  The first best hit on Google for "java war structure" is
>>> this:
>>>
>>>     http://www.onjava.com/pub/a/onjava/2001/03/15/tomcat.html
>>>
>>>
>>>> In the webindex you will find the index consists of:
>>>> _9m.cfs
>>>> delateable
>>>> segments
>>>>
>>>
>>> delateable?   That is an incorrect name.  Is this a typo in your mail
>>> or did you rename the file when you uploaded the index?   Is it
>>> possible that you mangled the index during the upload?
>>>
>>>
>>>> And the same files are working excellent on my PC at home and show
>>>> results
>>>> and on the Internet everything works but there are no results.
>>>>
>>>
>>> Are you catching and ignoring any exceptions?  Have you modified the
>>> JSP pages from your original configuration?  Are you pointing to the
>>> right index location on your server?
>>>
>>>     Erik
>>>
>>>
>>
> 


Mime
View raw message