lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dawid Weiss <dawid.we...@gmail.com>
Subject Re: Solr Gradle build (SOLR-13452)
Date Wed, 13 Nov 2019 10:28:21 GMT
I would really like you help out but you seem special. ;) Is your
checkout clean (git clean -xfd .), do you have any locally modified
files (git status)? I just ran ./gradlew jarChecksums on two different
machines (Windows, Linux) and everything passed, look:

:~/work-ssd/lucene-solr$ ./gradlew jarChecksums
Starting a Gradle Daemon, 1 incompatible Daemon could not be reused,
use --status for details

> Task :buildSrc:jar
:jar: No valid plugin descriptors were found in META-INF/gradle-plugins

> Configure project :
not user home user.gradle /home/dweiss/user.properties

BUILD SUCCESSFUL in 9m 19s
2 actionable tasks: 2 executed

> Execution failed for task ':solr:jarChecksums'.
> > Could not resolve all dependencies for configuration ':solr:solr-ref-guide:tools'.
>    > Could not find org.asciidoctor:asciidoctorj:.
>      Required by:
>          project :solr:solr-ref-guide

The dependency is defined in versions.props so I don't see any reason
why it'd be empty (log above). That changing version number to 1.6.2
makes the above pass for you is an even larger head-scratcher...

Make sure you have a clean unmodified checkout, stop any running
daemons (gradlew --stop) and try again with "--debug" switch passed to
gradlew -- send the output to me in private; maybe I'll be able to
figure it out (but I don't promise anything - palantir's plugin does
some black magic stuff around dependency resolution so it may as well
be a bug in their implementation somewhere).

Dawid

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message