lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Atri Sharma (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-8791) Add CollectorRescorer
Date Fri, 03 May 2019 06:12:00 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-8791?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16832281#comment-16832281
] 

Atri Sharma commented on LUCENE-8791:
-------------------------------------

Hi [~elbek.dev@gmail.com],

 

A few comments:

 

1) A better naming scheme would be helpful (eg. exec could be renamed to execManager for better
context, ditto for pending docIDs list, using verbose names for objects instead of "Collector
c")

2) Please have a look again at the spacing. In general, it would be good if the code was a
bit more readable w.r.t spacing around braces, breaking the code into logical paragraphes.

3) Could the class Job have a better name? Maybe RescoreTask?

4) Same for the class Jobs.

5) Please add a descriptive error message in the assert for ensuring that the docID post skipping
a segment is higher than the maxDoc.

6) In general, I am a bit unsure about the class name and description. The class advertises
to be a Collector based rescorer implementation, whereas the only constructor of the class
takes a CollectorManager instance, which is specific to parallel segments traversal. Should
the class say that it is used for parallel rescoring of hits across multiple segments?

7) I am a bit wary of the way the patch maps the global jobs array to jobs associated with
segments belonging to one slice. In particular, buildJobs method does not consider leaf ordinal
during assigning values to the global array, but rescore depends on that during retrieval.

> Add CollectorRescorer
> ---------------------
>
>                 Key: LUCENE-8791
>                 URL: https://issues.apache.org/jira/browse/LUCENE-8791
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Elbek Kamoliddinov
>            Priority: Major
>         Attachments: LUCENE-8791.patch
>
>
> This is another implementation of query rescorer api (LUCENE-5489). It adds rescoring
functionality based on provided CollectorManager. 
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message