lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-13335) Upgrade to velocity 2.0 and velocity-tools 3.0
Date Wed, 01 May 2019 09:17:00 GMT

    [ https://issues.apache.org/jira/browse/SOLR-13335?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16830928#comment-16830928
] 

ASF subversion and git services commented on SOLR-13335:
--------------------------------------------------------

Commit 37f0e1c68a6b6a5214a462a924ba7c1f2aa5bd19 in lucene-solr's branch refs/heads/branch_8_1
from Ishan Chattopadhyaya
[ https://gitbox.apache.org/repos/asf?p=lucene-solr.git;h=37f0e1c ]

SOLR-13335: Fix addVersion.py script that references velocity versions


> Upgrade to velocity 2.0 and velocity-tools 3.0
> ----------------------------------------------
>
>                 Key: SOLR-13335
>                 URL: https://issues.apache.org/jira/browse/SOLR-13335
>             Project: Solr
>          Issue Type: Improvement
>      Security Level: Public(Default Security Level. Issues are Public) 
>            Reporter: Kevin Risden
>            Assignee: Kevin Risden
>            Priority: Major
>             Fix For: 8.1, master (9.0)
>
>         Attachments: SOLR-13335.patch, SOLR-13335.patch, SOLR-13335.patch, SOLR-13335.patch,
SOLR-13335.patch, SOLR-13335.patch
>
>          Time Spent: 20m
>  Remaining Estimate: 0h
>
> As part of looking to remove old commons-lang in SOLR-9079, found that velocity depends
on it. Upgrading Velocity would allow completely removing commons-lang
> Copy some detail from SOLR-9079 investigation:
> * solr/contrib/velocity/ivy.xml doesn't even reference commons-lang
> * velocity 1.7 was released - 2010-11-29
> * LUCENE-5249 from 2013 was the last time velocity was changed in lucene/ivy-versions.properties
> * velocity-tools 2.0 has an optional dependency on commons-lang
> * velocity 1.7 has a hard dependency on commons-lang.
> Upgrading velocity 1.7 -> 2.0
> * http://velocity.apache.org/engine/2.0/upgrading.html
> * Change velocity to velocity-engine-core
> * upgrades commons-lang to commons-lang3
> So if we want to finish removing commons-lang, we need to upgrade velocity.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message