lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject [JENKINS] Solr-reference-guide-master - Build # 15909 - Still Failing
Date Thu, 16 May 2019 07:05:08 GMT
Build: https://builds.apache.org/job/Solr-reference-guide-master/15909/

Log: 
Started by timer
[EnvInject] - Loading node environment variables.
Building remotely on websites1 (git-websites svn-websites) in workspace /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master
No credentials specified
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url https://gitbox.apache.org/repos/asf/lucene-solr.git # timeout=10
Cleaning workspace
 > git rev-parse --verify HEAD # timeout=10
Resetting working tree
 > git reset --hard # timeout=10
 > git clean -fdx # timeout=10
Fetching upstream changes from https://gitbox.apache.org/repos/asf/lucene-solr.git
 > git --version # timeout=10
 > git fetch --tags --progress https://gitbox.apache.org/repos/asf/lucene-solr.git +refs/heads/*:refs/remotes/origin/*
 > git rev-parse refs/remotes/origin/master^{commit} # timeout=10
 > git rev-parse refs/remotes/origin/origin/master^{commit} # timeout=10
Checking out Revision 3a88ab616c9c8debe1f3a10e291697083eda3342 (refs/remotes/origin/master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 3a88ab616c9c8debe1f3a10e291697083eda3342
Commit message: "SOLR-13467: Include the S2 Geometry lib to make it simpler to use prefixTree="s2"
on a Geo3D spatial field. * Improved documentation on Geo3D. * Better testing for Geo3D."
 > git rev-list --no-walk 3a88ab616c9c8debe1f3a10e291697083eda3342 # timeout=10
No emails were triggered.
[Solr-reference-guide-master] $ /bin/bash -xe /tmp/jenkins7620140070793470239.sh
+ bash dev-tools/scripts/jenkins.build.ref.guide.sh
+ set -e
+ RVM_PATH=/home/jenkins/.rvm
+ RUBY_VERSION=ruby-2.3.3
+ GEMSET=solr-refguide-gemset
+ curl -sSL https://get.rvm.io
+ bash -s -- --ignore-dotfiles stable
Turning on ignore dotfiles mode.
Downloading https://github.com/rvm/rvm/archive/1.29.8.tar.gz
Downloading https://github.com/rvm/rvm/releases/download/1.29.8/1.29.8.tar.gz.asc
gpg: Signature made Wed 08 May 2019 02:14:49 PM UTC using RSA key ID 39499BDB
gpg: Good signature from "Piotr Kuczynski <piotr.kuczynski@gmail.com>"
gpg: WARNING: This key is not certified with a trusted signature!
gpg:          There is no indication that the signature belongs to the owner.
Primary key fingerprint: 7D2B AF1C F37B 13E2 069D  6956 105B D0E7 3949 9BDB
GPG verified '/home/jenkins/shared/.rvm/archives/rvm-1.29.8.tgz'
Upgrading the RVM installation in /home/jenkins/shared/.rvm/
Upgrade of RVM in /home/jenkins/shared/.rvm/ is complete.
  * It looks like some old stuff is laying around RVM, you can cleanup with: <code>rvm
cleanup all</code>


<warn>Thanks for installing RVM 🙏</warn>
Please consider donating to our open collective to help us maintain RVM.

👉  Donate: <code>https://opencollective.com/rvm/donate</code>


+ set +x
Running 'source /home/jenkins/.rvm/scripts/rvm'
Running 'rvm cleanup all'
Warning! PATH is not properly set up, /home/jenkins/shared/.rvm/gems/ruby-2.3.3/bin is not
at first place.
         <log>Usually this is caused by shell initialization files. Search for <code>PATH=...</code>
entries.
         You can also re-add RVM to your profile by running: <code>rvm get stable --auto-dotfiles</code>
         To fix it temporarily in this shell session run: <code>rvm use ruby-2.3.3</code>
         To ignore this error add <code>rvm_silence_path_mismatch_check_flag=1</code>
to your <code>~/.rvmrc</code> file.
Cleaning up rvm archives
Cleaning up rvm repos
Cleaning up rvm src
Cleaning up rvm log
Cleaning up rvm tmp
Cleaning up rvm gemsets
Cleaning up rvm links
Cleanup done.
Running 'rvm autolibs disable'
Warning! PATH is not properly set up, /home/jenkins/shared/.rvm/gems/ruby-2.3.3/bin is not
at first place.
         <log>Usually this is caused by shell initialization files. Search for <code>PATH=...</code>
entries.
         You can also re-add RVM to your profile by running: <code>rvm get stable --auto-dotfiles</code>
         To fix it temporarily in this shell session run: <code>rvm use ruby-2.3.3</code>
         To ignore this error add <code>rvm_silence_path_mismatch_check_flag=1</code>
to your <code>~/.rvmrc</code> file.
Running 'rvm install ruby-2.3.3'
Warning! PATH is not properly set up, /home/jenkins/shared/.rvm/gems/ruby-2.3.3/bin is not
at first place.
         <log>Usually this is caused by shell initialization files. Search for <code>PATH=...</code>
entries.
         You can also re-add RVM to your profile by running: <code>rvm get stable --auto-dotfiles</code>
         To fix it temporarily in this shell session run: <code>rvm use ruby-2.3.3</code>
         To ignore this error add <code>rvm_silence_path_mismatch_check_flag=1</code>
to your <code>~/.rvmrc</code> file.
Already installed ruby-2.3.3.
To reinstall use:

    rvm reinstall ruby-2.3.3

Running 'rvm gemset create solr-refguide-gemset'
ruby-2.3.3 - #gemset created /home/jenkins/shared/.rvm/gems/ruby-2.3.3@solr-refguide-gemset
ruby-2.3.3 - #generating solr-refguide-gemset wrappers|/-\|/-\|.-\|/-\|/-.|/-\|/-\|.-\|/-\|/-.|/-\|/-\|.-\|/-\|/-.|/-\|/-\.
Running 'rvm ruby-2.3.3@solr-refguide-gemset'
Using /home/jenkins/shared/.rvm/gems/ruby-2.3.3 with gemset solr-refguide-gemset
Running 'gem install --force --version 3.5.0 jekyll'
Successfully installed jekyll-3.5.0
Parsing documentation for jekyll-3.5.0
Done installing documentation for jekyll after 2 seconds
1 gem installed
Running 'gem uninstall --all --ignore-dependencies asciidoctor'
Removing asciidoctor
Removing asciidoctor-safe
Successfully uninstalled asciidoctor-1.5.6.2
Running 'gem install --force --version 1.5.6.2 asciidoctor'
Successfully installed asciidoctor-1.5.6.2
Parsing documentation for asciidoctor-1.5.6.2
Installing ri documentation for asciidoctor-1.5.6.2
Done installing documentation for asciidoctor after 5 seconds
1 gem installed
Running 'gem install --force --version 2.1.0 jekyll-asciidoc'
Successfully installed jekyll-asciidoc-2.1.0
Parsing documentation for jekyll-asciidoc-2.1.0
Done installing documentation for jekyll-asciidoc after 0 seconds
1 gem installed
Running 'gem install --force --version 1.1.2 pygments.rb'
Successfully installed pygments.rb-1.1.2
Parsing documentation for pygments.rb-1.1.2
Done installing documentation for pygments.rb after 0 seconds
1 gem installed
Running 'gem install --force --version 3.0.9 slim'
Successfully installed slim-3.0.9
Parsing documentation for slim-3.0.9
Done installing documentation for slim after 0 seconds
1 gem installed
+ ant clean build-site build-pdf
Buildfile: /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/solr-ref-guide/build.xml

clean:

build-init:
    [mkdir] Created dir: /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/content
     [echo] Copying all non template files from src ...
     [copy] Copying 477 files to /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/content
     [echo] Copy (w/prop replacement) any template files from src...
     [copy] Copying 1 file to /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/content

ivy-availability-check:
[loadresource] Do not set property disallowed.ivy.jars.list as its length is 0.

-ivy-fail-disallowed-ivy-version:

ivy-fail:

ivy-configure:
[ivy:configure] :: Apache Ivy 2.4.0 - 20141213170938 :: http://ant.apache.org/ivy/ ::
[ivy:configure] :: loading settings :: file = /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/lucene/top-level-ivy-settings.xml

resolve:

build-tools-jar:
    [mkdir] Created dir: /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/classes
    [javac] Compiling 4 source files to /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/classes
    [javac] warning: No processor claimed any of these annotations: java.base/java.lang.SuppressWarnings
    [javac] 1 warning
     [copy] Copying 1 file to /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/classes
      [jar] Building jar: /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/solr-ref-guide-tools.jar

build-nav-data-files:
     [java] Building up tree of all known pages
     [java] unsupported Java version "11", defaulting to 1.7
     [java] WARNING: An illegal reflective access operation has occurred
     [java] WARNING: Illegal reflective access by org.jruby.util.io.FilenoUtil (file:/home/jenkins/.ivy2/cache/org.asciidoctor/asciidoctor-ant/jars/asciidoctor-ant-1.6.0-alpha.5.jar)
to method sun.nio.ch.SelChImpl.getFD()
     [java] WARNING: Please consider reporting this to the maintainers of org.jruby.util.io.FilenoUtil
     [java] WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective
access operations
     [java] WARNING: All illegal access operations will be denied in a future release
     [java] Creating /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/content/_data/pdf-main-body.adoc
     [java] Creating /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/content/_data/scrollnav.json
     [java] Creating /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/content/_data/sidebar.json

-build-site:
     [echo] Running Jekyll...
     [exec] Configuration file: /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/content/_config.yml
     [exec]             Source: /home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/content
     [exec]        Destination: ../html-site
     [exec]  Incremental build: disabled. Enable with --incremental
     [exec]       Generating... 
     [exec]        Deprecation: The 'gems' configuration option has been renamed to 'plugins'.
Please update your config file accordingly.
     [exec] asciidoctor: WARNING: gem 'thread_safe' is not installed. This gem is recommended
when using custom backend templates.
     [exec]                     done in 20.259 seconds.
     [exec]  Auto-regeneration: disabled. Use --watch to enable.

build-site:
     [java] ID occurs multiple times: v1getcomponent
     [java]  ... file:/home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/html-site/config-api.html
     [java]  ... file:/home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/html-site/solrcloud-autoscaling-api.html
     [java] ID occurs multiple times: v2getcomponent
     [java]  ... file:/home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/html-site/config-api.html
     [java]  ... file:/home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/html-site/solrcloud-autoscaling-api.html
     [java] Relative link points at id that doesn't exist in dest: solrcloud-autoscaling-api.html#write-api
     [java]  ... source: file:/home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/html-site/solrcloud-autoscaling-triggers.html
     [java] Relative link points at id that doesn't exist in dest: solrcloud-autoscaling-api.html#create-update-trigger
     [java]  ... source: file:/home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/html-site/solrcloud-autoscaling-triggers.html
     [java] Relative link points at id that doesn't exist in dest: solrcloud-autoscaling-api.html#remove-trigger
     [java]  ... source: file:/home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/html-site/solrcloud-autoscaling-triggers.html
     [java] Relative link points at id that doesn't exist in dest: solrcloud-autoscaling-api.html#create-and-modify-cluster-preferences
     [java]  ... source: file:/home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/html-site/solrcloud-autoscaling-policy-preferences.html
     [java] Relative link points at id that doesn't exist in dest: solrcloud-autoscaling-api.html#create-and-modify-collection-specific-policy
     [java]  ... source: file:/home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/html-site/solrcloud-autoscaling-policy-preferences.html
     [java] Relative link points at id that doesn't exist in dest: solrcloud-autoscaling-api.html#change-autoscaling-properties
     [java]  ... source: file:/home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/build/solr-ref-guide/html-site/solr-upgrade-notes.html
     [java] Processed 2511 links (1822 relative) to 3348 anchors in 253 files
     [java] Total of 8 problems found

BUILD FAILED
/home/jenkins/jenkins-slave/workspace/Solr-reference-guide-master/solr/solr-ref-guide/build.xml:289:
Java returned: 255

Total time: 36 seconds
Build step 'Execute shell' marked build as failure
Archiving artifacts
Publishing Javadoc
Email was triggered for: Failure - Any
Sending email for trigger: Failure - Any

Mime
View raw message