lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Koji Sekiguchi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-8420) Upgrade OpenNLP to 1.9.0
Date Sat, 21 Jul 2018 03:40:00 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-8420?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16551519#comment-16551519
] 

Koji Sekiguchi commented on LUCENE-8420:
----------------------------------------

I created model files for 1.9.0 by executing ant train-test-models under lucene/analysis/opennlp/.
As for the training data, I renamed ner_flashman.txt to ner.txt and let the file have location
type for SOLR-12570.

I deleted opennlp-maxent which is never used (and I think it's old; opennlp-tools package
includes maxent).

> Upgrade OpenNLP to 1.9.0
> ------------------------
>
>                 Key: LUCENE-8420
>                 URL: https://issues.apache.org/jira/browse/LUCENE-8420
>             Project: Lucene - Core
>          Issue Type: Task
>          Components: modules/analysis
>    Affects Versions: 7.4
>            Reporter: Koji Sekiguchi
>            Priority: Minor
>             Fix For: master (8.0), 7.5
>
>         Attachments: LUCENE-8420.patch
>
>
> OpenNLP 1.9.0 generates new format model file which 1.8.x cannot read. 1.9.0 can read
the previous format for back-compat.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message