lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Georg Sorst (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-12367) When adding a model referencing a non-existent feature the error message is very ambiguous
Date Thu, 17 May 2018 07:10:00 GMT

    [ https://issues.apache.org/jira/browse/SOLR-12367?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16478639#comment-16478639
] 

Georg Sorst commented on SOLR-12367:
------------------------------------

I just noticed the same also happens when setting the weight of an (existing) feature to an
integer instead of a float, ie.

 

{{curl -XPUT 'http://localhost:8983/solr/gettingstarted/schema/model-store' --data-binary
'}}

{

{{  "class": "org.apache.solr.ltr.model.LinearModel",}}

{{  "name": "myModel",}}

{{  "features": [ \{"name": "whatever" }],}}

{{  "params": {"weights": {"whatever": 1}}}}

{{}' -H 'Content-type:application/json'}}

 

will also throw "Model type does not exist {{org.apache.solr.ltr.model.LinearModel}}". If
you change the weight to 1.0 it will work fine (if the feature "whatever" exists).

> When adding a model referencing a non-existent feature the error message is very ambiguous
> ------------------------------------------------------------------------------------------
>
>                 Key: SOLR-12367
>                 URL: https://issues.apache.org/jira/browse/SOLR-12367
>             Project: Solr
>          Issue Type: Improvement
>      Security Level: Public(Default Security Level. Issues are Public) 
>          Components: contrib - LTR
>    Affects Versions: 7.3.1
>            Reporter: Georg Sorst
>            Priority: Minor
>
> When adding a model that references a non-existent feature a very ambiguous error message
is thrown, something like "Model type does not exist org.apache.solr.ltr.model.{{LinearModel}}".
>  
> To reproduce, do not add any features and just add a model, for example by doing this:
>  
> {{curl -XPUT 'http://localhost:8983/solr/gettingstarted/schema/model-store' --data-binary
'}}
> {
> {{  "class": "org.apache.solr.ltr.model.LinearModel",}}
> {{  "name": "myModel",}}
> {{  "features": [ \{"name": "whatever" }],}}
> {{  "params": {"weights": {"whatever": 1.0}}}}
> {{}' -H 'Content-type:application/json'}}
>  
> The resulting error message "Model type does not exist {{org.apache.solr.ltr.model.LinearModel"
is extremely misleading and cost me a while to figure out the actual cause.}}
>  
> A more suitable error message should probably indicate the name of the missing feature
that the model is trying to reference.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message