lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Rowe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-8278) UAX29URLEmailTokenizer is not detecting some tokens as URL type
Date Fri, 25 May 2018 04:27:00 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-8278?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16490211#comment-16490211
] 

Steve Rowe commented on LUCENE-8278:
------------------------------------

I suspect this behavior is caused as a side-effect of the fix for LUCENE-5391.

> UAX29URLEmailTokenizer is not detecting some tokens as URL type
> ---------------------------------------------------------------
>
>                 Key: LUCENE-8278
>                 URL: https://issues.apache.org/jira/browse/LUCENE-8278
>             Project: Lucene - Core
>          Issue Type: Bug
>            Reporter: Junte Zhang
>            Priority: Minor
>
> We are using the UAX29URLEmailTokenizer so we can use the token types in our plugins.
> However, I noticed that the tokenizer is not detecting certain URLs as <URL> but
<ALPHANUM> instead.
> Examples that are not working:
>  * example.com is <ALPHANUM>
>  * example.net is <ALPHANUM>
> But:
>  * https://example.com is <URL>
>  * as is https://example.net
> Examples that work:
>  * example.ch is <URL>
>  * example.co.uk is <URL>
>  * example.nl is <URL>
> I have checked this JIRA, and could not find an issue. I have tested this on Lucene (Solr)
6.4.1 and 7.3.
> Could someone confirm my findings and advise what I could do to (help) resolve this issue?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message