lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-8248) Rename MergePolicyWrapper to FilterMergePolicy and override all of MergePolicy
Date Wed, 11 Apr 2018 16:53:00 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-8248?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16434208#comment-16434208
] 

Michael McCandless commented on LUCENE-8248:
--------------------------------------------

Thanks [~msokolov@gmail.com], new patch looks great.

Except, I was confused about {{NoMergePolicy}} (I somehow though it extended {{MergePolicyWrapper}}
but it just extends {{MergePolicy}} directly) – so, I think we should restore its test that
all methods are overridden (and add back its methods)?  (In addition to testing that {{FilterMergePolicy}}
also overrides all methods).

> Rename MergePolicyWrapper to FilterMergePolicy and override all of MergePolicy
> ------------------------------------------------------------------------------
>
>                 Key: LUCENE-8248
>                 URL: https://issues.apache.org/jira/browse/LUCENE-8248
>             Project: Lucene - Core
>          Issue Type: Wish
>          Components: core/index
>            Reporter: Mike Sokolov
>            Priority: Minor
>         Attachments: LUCENE-8248.1.patch, LUCENE-8248.patch, MergePolicy.patch
>
>
> MergePolicy.getMaxCFSSegmentSizeMB is final, but the corresponding setter is not, which
means that overriding it with anything other than a trivial delegation can only lead to confusion.
> The patch makes the method final and removes the trivial implementations from MergePolicyWrapper
and NoMergePolicy.
> [~mikemccand] also pointed out that the class name is nonstandard for similar adapter
classes in Lucene, which are usually Filter*.java. Personally I was looking for MergePolicyAdapter,
but if there is a prevailing convention here around Filter, does it make sense to change this
class's name to FilterMergePolicy?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message