lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-8248) Make MergePolicy.setMaxCFSSegmentSizeMB final
Date Wed, 11 Apr 2018 14:22:00 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-8248?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16433981#comment-16433981
] 

Michael McCandless commented on LUCENE-8248:
--------------------------------------------

Ahh thank you for the new patch; it looks great!

> I also had to add these overrides to {{NoMergePolicy}} in order to get its test to
pass since it verifies that all methods are overridden?

Ahh that's great it tests for that; actually, could you please add exactly that same test
for {{FilterMergePolicy}} (and I think remove it from the test for {{NoMergePolicy}}). This
way if we add new methods to {{MergePolicy}} the test failure will remind us to update {{FilterMergePolicy}}
too.

> Make MergePolicy.setMaxCFSSegmentSizeMB final
> ---------------------------------------------
>
>                 Key: LUCENE-8248
>                 URL: https://issues.apache.org/jira/browse/LUCENE-8248
>             Project: Lucene - Core
>          Issue Type: Wish
>          Components: core/index
>            Reporter: Mike Sokolov
>            Priority: Minor
>         Attachments: LUCENE-8248.patch, MergePolicy.patch
>
>
> MergePolicy.getMaxCFSSegmentSizeMB is final, but the corresponding setter is not, which
means that overriding it with anything other than a trivial delegation can only lead to confusion.
> The patch makes the method final and removes the trivial implementations from MergePolicyWrapper
and NoMergePolicy.
> [~mikemccand] also pointed out that the class name is nonstandard for similar adapter
classes in Lucene, which are usually Filter*.java. Personally I was looking for MergePolicyAdapter,
but if there is a prevailing convention here around Filter, does it make sense to change this
class's name to FilterMergePolicy?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message