lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Woodward <romseyg...@gmail.com>
Subject Re: lucene-solr:branch_7_3: LUCENE-8224: Allow releases to be built with ant 1.10
Date Mon, 26 Mar 2018 15:35:22 GMT
Oops, thanks Uwe

> On 26 Mar 2018, at 14:42, Uwe Schindler <uwe@thetaphi.de> wrote:
> 
> There is a typo in the common build error message.
> 
> Uwe
> 
> Am March 26, 2018 1:06:43 PM UTC schrieb romseygeek@apache.org:
> Repository: lucene-solr
> Updated Branches:
>   refs/heads/branch_7_3 eb8a5a882 -> ad93c1c48
> 
> 
> LUCENE-8224: Allow releases to be built with ant 1.10
> 
> Also adds a check to common-build.xml to fail early with ant 1.10.2, which
> has a bug that prevents lucene from building.
> 
> 
> Project: http://git-wip-us.apache.org/repos/asf/lucene-solr/repo <http://git-wip-us.apache.org/repos/asf/lucene-solr/repo>
> Commit: http://git-wip-us.apache.org/repos/asf/lucene-solr/commit/ad93c1c4 <http://git-wip-us.apache.org/repos/asf/lucene-solr/commit/ad93c1c4>
> Tree: http://git-wip-us.apache.org/repos/asf/lucene-solr/tree/ad93c1c4 <http://git-wip-us.apache.org/repos/asf/lucene-solr/tree/ad93c1c4>
> Diff: http://git-wip-us.apache.org/repos/asf/lucene-solr/diff/ad93c1c4 <http://git-wip-us.apache.org/repos/asf/lucene-solr/diff/ad93c1c4>
> 
> Branch: refs/heads/branch_7_3
> Commit: ad93c1c489444fc8f8d5aed8bfe6e8fef2b84789
> Parents: eb8a5a8
> Author: Alan Woodward <romseygeek@apache.org>
> Authored: Mon Mar 26 12:00:12 2018 +0100
> Committer: Alan Woodward <romseygeek@apache.org>
> Committed: Mon Mar 26 14:05:59 2018 +0100
> 
> 
>  dev-tools/scripts/buildAndPushRelease.py | 11 +++++------
>  dev-tools/scripts/smokeTestRelease.py    |  4 ++--
>  lucene/common-build.xml                  |  6 ++++++
>  3 files changed, 13 insertions(+), 8 deletions(-)
> 
> 
> 
> http://git-wip-us.apache.org/repos/asf/lucene-solr/blob/ad93c1c4/dev-tools/scripts/buildAndPushRelease.py
<http://git-wip-us.apache.org/repos/asf/lucene-solr/blob/ad93c1c4/dev-tools/scripts/buildAndPushRelease.py>
> 
> diff --git a/dev-tools/scripts/buildAndPushRelease.py b/dev-tools/scripts/buildAndPushRelease.py
> index 3781eb4..417bd3d 100644
> --- a/dev-tools/scripts/buildAndPushRelease.py
> +++ b/dev-tools/scripts/buildAndPushRelease.py
> @@ -288,16 +288,15 @@ def check_cmdline_tools():  # Fail fast if there are cmdline tool
problems
>      raise RuntimeError('"git --version" returned a non-zero exit code.')
>    check_ant()
>  
> -def check_ant(): # allow 1.8, 1.9, 1.10
> +def check_ant():
>    antVersion = os.popen('ant -version').read().strip()
> -  if antVersion.startswith('Apache Ant(TM) version 1.8'):
> +  if (antVersion.startswith('Apache Ant(TM) version 1.8')):
>      return
> -  if antVersion.startswith('Apache Ant(TM) version 1.9'):
> +  if (antVersion.startswith('Apache Ant(TM) version 1.9')):
>      return
> -  if antVersion.startswith('Apache Ant(TM) version 1.10'):
> +  if (antVersion.startswith('Apache Ant(TM) version 1.10')):
>      return
> -  raise RuntimeError('Unsupported ant version (expecting 1.8 - 1.10) :' + antVersion)
> -
> +  raise RuntimeError('Unsupported ant version (must be 1.8 - 1.10): "%s"' % antVersion)
>    
>  def main():
>    check_cmdline_tools()
> 
> http://git-wip-us.apache.org/repos/asf/lucene-solr/blob/ad93c1c4/dev-tools/scripts/smokeTestRelease.py
<http://git-wip-us.apache.org/repos/asf/lucene-solr/blob/ad93c1c4/dev-tools/scripts/smokeTestRelease.py>
> 
> diff --git a/dev-tools/scripts/smokeTestRelease.py b/dev-tools/scripts/smokeTestRelease.py
> index 2e6f1e6..33df9f4 100644
> --- a/dev-tools/scripts/smokeTestRelease.py
> +++ b/dev-tools/scripts/smokeTestRelease.py
> @@ -190,8 +190,8 @@ def checkJARMetaData(desc, jarFile, gitRevision, version):
>        'Implementation-Vendor: The Apache Software Foundation',
>        # Make sure 1.8 compiler was used to build release bits:
>        'X-Compile-Source-JDK: 8',
> -      # Make sure 1.8 or 1.9 ant was used to build release bits: (this will match 1.8.x,
1.9.x)
> -      ('Ant-Version: Apache Ant 1.8', 'Ant-Version: Apache Ant 1.9'),
> +      # Make sure 1.8, 1.9 or 1.10 ant was used to build release bits: (this will match
1.8.x, 1.9.x, 1.10.x)
> +      ('Ant-Version: Apache Ant 1.8', 'Ant-Version: Apache Ant 1.9', 'Ant-Version: Apache
Ant 1.10'),
>        # Make sure .class files are 1.8 format:
>        'X-Compile-Target-JDK: 8',
>        'Specification-Version: %s' % version,
> 
> http://git-wip-us.apache.org/repos/asf/lucene-solr/blob/ad93c1c4/lucene/common-build.xml
<http://git-wip-us.apache.org/repos/asf/lucene-solr/blob/ad93c1c4/lucene/common-build.xml>
> 
> diff --git a/lucene/common-build.xml b/lucene/common-build.xml
> index 86e4288..f3cf1d0 100644
> --- a/lucene/common-build.xml
> +++ b/lucene/common-build.xml
> @@ -282,6 +282,12 @@
>      </condition>
>    </fail>
>  
> +  <fail message="Cannot run with ANT version 1.0.2 - see https://issues.apache.org/jira/browse/LUCENE-8189
<https://issues.apache.org/jira/browse/LUCENE-8189>">
> +    <condition>
> +      <antversion exactly="1.10.2"/>
> +    </condition>
> +  </fail>
> +
>    <fail message="Minimum supported Java version is 1.8.">
>      <condition>
>        <not><hasmethod classname="java.util.Arrays" method="parallelSort"/></not>
> 
> 
> --
> Uwe Schindler
> Achterdiek 19, 28357 Bremen
> https://www.thetaphi.de <https://www.thetaphi.de/>

Mime
View raw message