lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Gainty <mgai...@hotmail.com>
Subject Re: Solr Ref Guide not building
Date Sat, 02 Dec 2017 19:15:04 GMT

as evidenced by the warning you're getting..your yaml scripts appear to reference deprecated
ruby gems

personally i dont care to implement ruby gems since these binaries work on ONLY the OS/ARCH
they were originally targeted for

a well designed software architecture implementing plugins will flexibly build to any number
of OS/ARCH with no need to <re>build for each specific target OS/ARCH  with makefile(s)
(as is the case for ruby gems) .


The caveat for implementing plugins is "as long as the JDK remains the same" you should see
no behaviour delta(s) as you implement your plugin from one OS/ARCH to another..


hth

Martin
______________________________________________


________________________________
From: Doug Turnbull <dturnbull@opensourceconnections.com>
Sent: Saturday, December 2, 2017 1:12 PM
To: dev@lucene.apache.org
Subject: Re: Solr Ref Guide not building

Thanks.

I don’t mind poking around the ref guide config, but I'm following the readme and building
master. I'm hesitant to change config files as part of my PR, which probably will break the
ref guide build for others :)

Best
-Doug


On Sat, Dec 2, 2017 at 7:37 AM Martin Gainty <mgainty@hotmail.com<mailto:mgainty@hotmail.com>>
wrote:


MG>see below


________________________________
From: Doug Turnbull <dturnbull@opensourceconnections.com<mailto:dturnbull@opensourceconnections.com>>
Sent: Friday, December 1, 2017 9:17 PM
To: dev@lucene.apache.org<mailto:dev@lucene.apache.org>
Subject: Solr Ref Guide not building

Hello!

I'm trying to update the Solr Ref guide with my change for SOLR-11662. I believe I've installed
the required dependencies and double checked the README in the solr-ref-guide. Unfortunately,
running ant build-site I immediately get this error, seemingly on the first adoc file encountered:


     [exec] jekyll 3.5.0 | Error:  No header received back.
     [exec]   Conversion error: Jekyll::AsciiDoc::Converter encountered an error while converting
'about-filters.adoc':
MG>possible ant build snafu
MG>configuration file: /Users/doug/ws/lucene-solr/solr/build/solr-ref-guide/content/_config.yml
MG>Deprecation: The 'gems' configuration option has been renamed to 'plugins'.
MG>Please update your config file accordingly.
MG>check output config.yml for 'gems' and sub in 'plugins'
MG>also check ant input solr-ref-guide/config.yml.template for 'gems' instead of 'plugins'

I feel like I must be doing something stupid (I'll assume user error on my part). But if there's
anything obvious I'm doing wrong, please let me know

A more complete log can be found here https://gist.github.com/softwaredoug/36fe87f0d63403e7be22d5a2ff8af073
[https://avatars1.githubusercontent.com/u/629060?s=400&v=4]<https://gist.github.com/softwaredoug/36fe87f0d63403e7be22d5a2ff8af073>

doug-being-dumb.txt<https://gist.github.com/softwaredoug/36fe87f0d63403e7be22d5a2ff8af073>
gist.github.com<http://gist.github.com>



Thanks for any help

-Doug
--
Consultant, OpenSource Connections. Contact info at http://o19s.com/about-us/doug-turnbull/;
Free/Busy (http://bit.ly/dougs_cal)
[http://opensourceconnections.com/images/logo/OSC-logomark-color.png]<http://o19s.com/about-us/doug-turnbull/>

Doug Turnbull<http://o19s.com/about-us/doug-turnbull/>
o19s.com<http://o19s.com>
Search relevance consultant. Author of Relevant Search. Doug crafts search/recommendation
solutions that “get” users. To do this, Doug uses Solr/Elasticsearc...


--
Consultant, OpenSource Connections. Contact info at http://o19s.com/about-us/doug-turnbull/;
Free/Busy (http://bit.ly/dougs_cal)

Mime
View raw message