lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nawab Zada Asad iqbal (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-11297) Message "Lock held by this virtual machine" during startup. Solr is trying to start some cores twice
Date Mon, 25 Sep 2017 21:43:00 GMT

    [ https://issues.apache.org/jira/browse/SOLR-11297?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16179831#comment-16179831
] 

Nawab Zada Asad iqbal commented on SOLR-11297:
----------------------------------------------

It seems that this error is difficult to reproduce. I tried Luiz's script on my Mac laptop
and wasn't able to reproduce this issue even after decreasing the 'sleep' between iteration
to `0.005`. I tried it on a production like machine (which is similar to what I had done last
month although using an haproxy instead of a command line script) and I was able to hit the
above error however my cores were still loaded by the 'Core' thread and were functional. Last
month when initially I hit this issue, my server was giving the above 'Lock held by this virtual
machine' error and also they were **not** usable. Unfortunately, I don't have access to those
specific machines anymore. 



> Message "Lock held by this virtual machine" during startup.  Solr is trying to start
some cores twice
> -----------------------------------------------------------------------------------------------------
>
>                 Key: SOLR-11297
>                 URL: https://issues.apache.org/jira/browse/SOLR-11297
>             Project: Solr
>          Issue Type: Bug
>      Security Level: Public(Default Security Level. Issues are Public) 
>    Affects Versions: 6.6
>            Reporter: Shawn Heisey
>            Assignee: Erick Erickson
>             Fix For: 7.1
>
>         Attachments: SOLR-11297.patch, SOLR-11297.patch, SOLR-11297.patch, SOLR-11297.sh,
solr6_6-startup.log
>
>
> Sometimes when Solr is restarted, I get some "lock held by this virtual machine" messages
in the log, and the admin UI has messages about a failure to open a new searcher.  It doesn't
happen on all cores, and the list of cores that have the problem changes on subsequent restarts.
 The cores that exhibit the problems are working just fine -- the first core load is successful,
the failure to open a new searcher is on a second core load attempt, which fails.
> None of the cores in the system are sharing an instanceDir or dataDir.  This has been
verified several times.
> The index is sharded manually, and the servers are not running in cloud mode.
> One critical detail to this issue: The cores are all perfectly functional.  If somebody
is seeing an error message that results in a core not working at all, then it is likely a
different issue.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message