lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Smiley (JIRA)" <>
Subject [jira] [Commented] (LUCENE-7738) Add new InetAddressRangeField
Date Sat, 11 Mar 2017 22:54:04 GMT


David Smiley commented on LUCENE-7738:

RE naming; some consistency is good.  So if the non-range variant doesn't have 'Field' then
don't put it on the range variant.  But vice-versa is also true -- consistency being most
important.  I care little wether both should have (or not have) a "Field" suffix.  There seems
to be a lot of variation across Lucene, unfortunately.

bq. I can open a separate issue to "Graduate Range Fields from sandbox" that will refactor
the range field class names and move them to the appropriate module?


> Add new InetAddressRangeField
> -----------------------------
>                 Key: LUCENE-7738
>                 URL:
>             Project: Lucene - Core
>          Issue Type: New Feature
>            Reporter: Nicholas Knize
>         Attachments: LUCENE-7738.patch, LUCENE-7738.patch
> This issue adda a new {{InetAddressRangeField}} for indexing and querying InetAddress

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message